summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-21 22:05:51 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-26 13:45:16 -0700
commit98c3afc5293e7aaf415e50940b2ddf5a235330f0 (patch)
tree01b176b4675e569ce8176c9e4c79a3db7c82d6ed
parent686c29d744a5c3b0766e50a137cca777e0c7cfe5 (diff)
downloadmeta-clang-98c3afc5293e7aaf415e50940b2ddf5a235330f0.tar.gz
wayland: Remove bbappend and patch
This is already there in 1.17 release Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-graphics/wayland/files/fix_duplicate_main.patch54
-rw-r--r--recipes-graphics/wayland/wayland_1.16.%.bbappend3
2 files changed, 0 insertions, 57 deletions
diff --git a/recipes-graphics/wayland/files/fix_duplicate_main.patch b/recipes-graphics/wayland/files/fix_duplicate_main.patch
deleted file mode 100644
index 9b9ec99..0000000
--- a/recipes-graphics/wayland/files/fix_duplicate_main.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1--- wayland-1.16.0/Makefile.am 2019-03-14 10:29:31.103099516 +0100
2+++ wayland-1.16.0/Makefile.am 2019-03-14 10:33:07.987977505 +0100
3@@ -210,12 +210,15 @@
4 exec-fd-leak-checker \
5 fixed-benchmark
6
7-noinst_LTLIBRARIES += libtest-runner.la
8+noinst_LTLIBRARIES += \
9+ libtest-runner.la \
10+ libtest-helpers.la
11+
12+libtest_helpers_la_SOURCES = tests/test-helpers.c
13
14 libtest_runner_la_SOURCES = \
15 tests/test-runner.c \
16 tests/test-runner.h \
17- tests/test-helpers.c \
18 tests/test-compositor.h \
19 tests/test-compositor.c
20 libtest_runner_la_LIBADD = \
21@@ -223,9 +226,9 @@
22 libwayland-util.la \
23 libwayland-client.la \
24 libwayland-server.la \
25+ libtest-helpers.la \
26 -lrt -ldl $(FFI_LIBS)
27
28-
29 array_test_SOURCES = tests/array-test.c
30 array_test_LDADD = libtest-runner.la
31 client_test_SOURCES = tests/client-test.c
32@@ -270,7 +273,6 @@
33 headers_test_SOURCES = tests/headers-test.c \
34 tests/headers-protocol-test.c \
35 tests/headers-protocol-core-test.c
36-headers_test_LDADD = libtest-runner.la
37 nodist_headers_test_SOURCES = \
38 protocol/wayland-server-protocol-core.h \
39 protocol/wayland-client-protocol-core.h
40@@ -280,13 +282,12 @@
41 endif
42
43 fixed_benchmark_SOURCES = tests/fixed-benchmark.c
44-fixed_benchmark_LDADD = libtest-runner.la
45
46 os_wrappers_test_SOURCES = tests/os-wrappers-test.c
47 os_wrappers_test_LDADD = libtest-runner.la
48
49 exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c
50-exec_fd_leak_checker_LDADD = libtest-runner.la
51+exec_fd_leak_checker_LDADD = libtest-helpers.la
52
53 EXTRA_DIST += tests/scanner-test.sh \
54 protocol/tests.xml \
diff --git a/recipes-graphics/wayland/wayland_1.16.%.bbappend b/recipes-graphics/wayland/wayland_1.16.%.bbappend
deleted file mode 100644
index 6d9a72d..0000000
--- a/recipes-graphics/wayland/wayland_1.16.%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append = " file://fix_duplicate_main.patch "