summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastaG <mastag@gmail.com>2019-03-14 11:12:37 +0100
committerKhem Raj <raj.khem@gmail.com>2019-03-15 08:57:55 -0700
commit80bde5b1af11ae40b4931f5960effff6f6ab44ba (patch)
treea1ce0f0a77401df6b90a4817ea42c02170816f52
parent2705ac1c920a2cc45701035c1a30c152cd26817f (diff)
downloadmeta-clang-80bde5b1af11ae40b4931f5960effff6f6ab44ba.tar.gz
Fix duplicates symbols when building with lld
Samba: https://svnweb.freebsd.org/ports/branches/2018Q4/net/samba47/files/patch-source3__wscript_build?view=markup&pathrev=481551 Wayland: https://gitlab.freedesktop.org/wayland/wayland/commit/c70fd8a812d74b5ef6fcba1287b409f4f8821e91
-rw-r--r--recipes-connectivity/samba/files/fix_duplicate_pdb_search_init.patch10
-rw-r--r--recipes-connectivity/samba/samba_4.8.%.bbappend3
-rw-r--r--recipes-graphics/wayland/files/fix_duplicate_main.patch54
-rw-r--r--recipes-graphics/wayland/wayland_1.16.%.bbappend3
4 files changed, 70 insertions, 0 deletions
diff --git a/recipes-connectivity/samba/files/fix_duplicate_pdb_search_init.patch b/recipes-connectivity/samba/files/fix_duplicate_pdb_search_init.patch
new file mode 100644
index 0000000..e9d88d2
--- /dev/null
+++ b/recipes-connectivity/samba/files/fix_duplicate_pdb_search_init.patch
@@ -0,0 +1,10 @@
1--- a/source3/wscript_build 2019-03-14 09:03:29.498617250 +0100
2+++ b/source3/wscript_build 2019-03-14 09:06:19.824949694 +0100
3@@ -124,7 +124,6 @@
4 '!get_attr_list']
5 private_pdb_match.append('!pdb_nds_*')
6 private_pdb_match.append('!pdb_ldapsam_init*')
7-private_pdb_match.append('!pdb_*_init')
8 private_pdb_match = private_pdb_match + ldapsam_pdb_match
9
10 bld.SAMBA3_LIBRARY('samba-passdb',
diff --git a/recipes-connectivity/samba/samba_4.8.%.bbappend b/recipes-connectivity/samba/samba_4.8.%.bbappend
new file mode 100644
index 0000000..dd0e5ca
--- /dev/null
+++ b/recipes-connectivity/samba/samba_4.8.%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append += " file://fix_duplicate_pdb_search_init.patch "
diff --git a/recipes-graphics/wayland/files/fix_duplicate_main.patch b/recipes-graphics/wayland/files/fix_duplicate_main.patch
new file mode 100644
index 0000000..9b9ec99
--- /dev/null
+++ b/recipes-graphics/wayland/files/fix_duplicate_main.patch
@@ -0,0 +1,54 @@
1--- wayland-1.16.0/Makefile.am 2019-03-14 10:29:31.103099516 +0100
2+++ wayland-1.16.0/Makefile.am 2019-03-14 10:33:07.987977505 +0100
3@@ -210,12 +210,15 @@
4 exec-fd-leak-checker \
5 fixed-benchmark
6
7-noinst_LTLIBRARIES += libtest-runner.la
8+noinst_LTLIBRARIES += \
9+ libtest-runner.la \
10+ libtest-helpers.la
11+
12+libtest_helpers_la_SOURCES = tests/test-helpers.c
13
14 libtest_runner_la_SOURCES = \
15 tests/test-runner.c \
16 tests/test-runner.h \
17- tests/test-helpers.c \
18 tests/test-compositor.h \
19 tests/test-compositor.c
20 libtest_runner_la_LIBADD = \
21@@ -223,9 +226,9 @@
22 libwayland-util.la \
23 libwayland-client.la \
24 libwayland-server.la \
25+ libtest-helpers.la \
26 -lrt -ldl $(FFI_LIBS)
27
28-
29 array_test_SOURCES = tests/array-test.c
30 array_test_LDADD = libtest-runner.la
31 client_test_SOURCES = tests/client-test.c
32@@ -270,7 +273,6 @@
33 headers_test_SOURCES = tests/headers-test.c \
34 tests/headers-protocol-test.c \
35 tests/headers-protocol-core-test.c
36-headers_test_LDADD = libtest-runner.la
37 nodist_headers_test_SOURCES = \
38 protocol/wayland-server-protocol-core.h \
39 protocol/wayland-client-protocol-core.h
40@@ -280,13 +282,12 @@
41 endif
42
43 fixed_benchmark_SOURCES = tests/fixed-benchmark.c
44-fixed_benchmark_LDADD = libtest-runner.la
45
46 os_wrappers_test_SOURCES = tests/os-wrappers-test.c
47 os_wrappers_test_LDADD = libtest-runner.la
48
49 exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c
50-exec_fd_leak_checker_LDADD = libtest-runner.la
51+exec_fd_leak_checker_LDADD = libtest-helpers.la
52
53 EXTRA_DIST += tests/scanner-test.sh \
54 protocol/tests.xml \
diff --git a/recipes-graphics/wayland/wayland_1.16.%.bbappend b/recipes-graphics/wayland/wayland_1.16.%.bbappend
new file mode 100644
index 0000000..7f80b96
--- /dev/null
+++ b/recipes-graphics/wayland/wayland_1.16.%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append += " file://fix_duplicate_main.patch "