summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-09 19:32:14 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-09 19:34:28 -0800
commit1cb1f5220069f6a72d0bbb321aa5bd02111826a0 (patch)
treea9e608112b7c9aadf5a2971d43635dfe736f4b2a
parentcc4e8f1fa898b075264ee860bcf82d4cfce94573 (diff)
downloadmeta-clang-1cb1f5220069f6a72d0bbb321aa5bd02111826a0.tar.gz
clang-nativesdk: Do not default to clang-runtime
This make it use same runtime as the cross compiler default, which is more or less what is going to be case, if one wants to use clang runtime then it should be enabled across all clang variants (native/nativesdk/cross) Fixes Issue #66 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/clang_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index f1f29c1..331e5cf 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -45,7 +45,7 @@ def get_clang_experimental_target_arch(bb, d):
45 45
46PACKAGECONFIG ??= "compiler-rt libcplusplus shared-libs ${@bb.utils.filter('DISTRO_FEATURES', 'thin-lto full-lto', d)}" 46PACKAGECONFIG ??= "compiler-rt libcplusplus shared-libs ${@bb.utils.filter('DISTRO_FEATURES', 'thin-lto full-lto', d)}"
47PACKAGECONFIG_class-native = "" 47PACKAGECONFIG_class-native = ""
48PACKAGECONFIG_class-nativesdk = "compiler-rt libcplusplus thin-lto ${@bb.utils.filter('DISTRO_FEATURES', 'full-lto', d)}" 48PACKAGECONFIG_class-nativesdk = "thin-lto ${@bb.utils.filter('DISTRO_FEATURES', 'full-lto', d)}"
49 49
50PACKAGECONFIG[compiler-rt] = "-DCLANG_DEFAULT_RTLIB=compiler-rt,,libcxx" 50PACKAGECONFIG[compiler-rt] = "-DCLANG_DEFAULT_RTLIB=compiler-rt,,libcxx"
51PACKAGECONFIG[libcplusplus] = "-DCLANG_DEFAULT_CXX_STDLIB=libc++,,libcxx" 51PACKAGECONFIG[libcplusplus] = "-DCLANG_DEFAULT_CXX_STDLIB=libc++,,libcxx"