summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-12 10:30:34 -0700
committerKhem Raj <raj.khem@gmail.com>2019-03-12 21:43:38 -0700
commit1b671b2256a937395cf7964c6a57d2e54f8f41ae (patch)
tree203b23d2dda91f4201d46b1da01ac4695b2f300a
parentacc1c430b9223609e619b67bf03c712ff77eafe1 (diff)
downloadmeta-clang-1b671b2256a937395cf7964c6a57d2e54f8f41ae.tar.gz
libcxx, compiler-rt: Use forcevariable to specify TOOLCHAIN override
This may already be specified by another low priority override to point to gcc but we want to always use clang for compiling these packages Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb2
-rw-r--r--recipes-devtools/clang/libcxx_git.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 3158380..9a15211 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -96,4 +96,4 @@ BBCLASSEXTEND = "native nativesdk"
96ALLOW_EMPTY_${PN} = "1" 96ALLOW_EMPTY_${PN} = "1"
97ALLOW_EMPTY_${PN}-dev = "1" 97ALLOW_EMPTY_${PN}-dev = "1"
98 98
99TOOLCHAIN = "clang" 99TOOLCHAIN_forcevariable = "clang"
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 26fbcdc..ad755b9 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -32,6 +32,7 @@ LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=3de3deb8323d5cf3360104190e804a
32" 32"
33THUMB_TUNE_CCARGS = "" 33THUMB_TUNE_CCARGS = ""
34#TUNE_CCARGS += "-nostdlib" 34#TUNE_CCARGS += "-nostdlib"
35EXTRA_OECMAKE_append_armv5 = " -D_LIBCXXABI_HAS_ATOMIC_BUILTINS=OFF"
35 36
36EXTRA_OECMAKE += "\ 37EXTRA_OECMAKE += "\
37 -DLIBCXX_CXX_ABI=libcxxabi \ 38 -DLIBCXX_CXX_ABI=libcxxabi \
@@ -76,4 +77,4 @@ ALLOW_EMPTY_${PN} = "1"
76RDEPENDS_${PN}-dev += "${PN}-staticdev" 77RDEPENDS_${PN}-dev += "${PN}-staticdev"
77 78
78BBCLASSEXTEND = "native nativesdk" 79BBCLASSEXTEND = "native nativesdk"
79TOOLCHAIN = "clang" 80TOOLCHAIN_forcevariable = "clang"