summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-06-18 07:27:37 +0800
committerKhem Raj <raj.khem@gmail.com>2019-06-18 05:58:08 -0700
commit13e63ae5bc92e43b7df0701edb8f1a2092fafaee (patch)
tree1025c5937723a9a1b2cdc997f438cd21aa4e261d
parentba3e396e7b20e7d56f08f3540e780ec1ad51ecfd (diff)
downloadmeta-clang-13e63ae5bc92e43b7df0701edb8f1a2092fafaee.tar.gz
lldb: ignore format-security warnings
lldb doesn't build when -Wformat-security -Werror=format-security is added/enabled and results in errors with gcc9: | BUILD/build/tmp/work-shared/llvm-project-source-8.0.1-r0/git/lldb/source/Core/Module.cpp: In member function 'size_t lldb_private::Module::FindTypes_Impl(const lldb_private::ConstString&, const lldb_private::CompilerDeclContext*, bool, size_t, llvm::DenseSet<lldb_private::SymbolFile*>&, lldb_private::TypeMap&)': | BUILD/build/tmp/work-shared/llvm-project-source-8.0.1-r0/git/lldb/source/Core/Module.cpp:951:52: error: format not a string literal and no format arguments [-Werror=format-security] | 951 | Timer scoped_timer(func_cat, LLVM_PRETTY_FUNCTION); | | ^ | BUILD/build/tmp/work-shared/llvm-project-source-8.0.1-r0/git/lldb/source/Core/Module.cpp: In member function 'virtual lldb_private::SymbolVendor* lldb_private::Module::GetSymbolVendor(bool, lldb_private::Stream*)': | BUILD/build/tmp/work-shared/llvm-project-source-8.0.1-r0/git/lldb/source/Core/Module.cpp:1052:58: error: format not a string literal and no format arguments [-Werror=format-security] | 1052 | Timer scoped_timer(func_cat, LLVM_PRETTY_FUNCTION); | | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-devtools/clang/lldb_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/lldb_git.bb b/recipes-devtools/clang/lldb_git.bb
index 7c4be42..5cfbdb7 100644
--- a/recipes-devtools/clang/lldb_git.bb
+++ b/recipes-devtools/clang/lldb_git.bb
@@ -45,6 +45,8 @@ EXTRA_OECMAKE="\
45 45
46EXTRA_OEMAKE = "VERBOSE=1" 46EXTRA_OEMAKE = "VERBOSE=1"
47 47
48CXXFLAGS_append_toolchain-gcc = " -Wno-error=format-security"
49
48do_compile() { 50do_compile() {
49 ninja ${PARALLEL_MAKE} lldb 51 ninja ${PARALLEL_MAKE} lldb
50} 52}