summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2019-01-16 09:03:17 -0600
committerKhem Raj <raj.khem@gmail.com>2019-01-16 07:34:43 -0800
commite82ff43b2f361a36d18ac9d09f119f02ca2ac989 (patch)
tree2a9a18768103d564597b0aab504cfe21c1f4e027
parentb6957fd1fc942ae5b0860f298b4e147b29f02ccb (diff)
downloadmeta-clang-e82ff43b2f361a36d18ac9d09f119f02ca2ac989.tar.gz
llvm-project: Switch to canonical git mirror
LLVM now has an official git monorepo mirror. It will likely become the canonical upstream in the near future. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
-rw-r--r--recipes-devtools/clang/clang.inc6
-rw-r--r--recipes-devtools/clang/common.inc2
-rw-r--r--recipes-devtools/clang/llvm-project-source.bb4
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-devtools/clang/clang.inc b/recipes-devtools/clang/clang.inc
index f2d4568..63c702c 100644
--- a/recipes-devtools/clang/clang.inc
+++ b/recipes-devtools/clang/clang.inc
@@ -1,17 +1,17 @@
1LLVM_RELEASE = "" 1LLVM_RELEASE = ""
2LLVM_DIR = "llvm${LLVM_RELEASE}" 2LLVM_DIR = "llvm${LLVM_RELEASE}"
3 3
4LLVM_GIT ?= "git://github.com/llvm-project" 4LLVM_GIT ?= "git://github.com/llvm"
5LLVM_GIT_PROTOCOL ?= "https" 5LLVM_GIT_PROTOCOL ?= "https"
6 6
7MAJOR_VER = "7" 7MAJOR_VER = "7"
8MINOR_VER = "0" 8MINOR_VER = "0"
9PATCH_VER = "1" 9PATCH_VER = "1"
10 10
11SRCREV ?= "b8e7044dd2e6e7af9e58cef99b840bd88cfd2dec" 11SRCREV ?= "d0d8eb2e5415b8be29343e3c17a18e49e67b5551"
12 12
13PV = "${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}" 13PV = "${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}"
14BRANCH = "release_${MAJOR_VER}${MINOR_VER}" 14BRANCH = "release/${MAJOR_VER}.x"
15 15
16LLVMMD5SUM = "c520ed40e11887bb1d24d86f7f5b1f05" 16LLVMMD5SUM = "c520ed40e11887bb1d24d86f7f5b1f05"
17CLANGMD5SUM = "444af0e124949f07f791f12c928e5994" 17CLANGMD5SUM = "444af0e124949f07f791f12c928e5994"
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index 1b4cf9b..d582d34 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://llvm/LICENSE.TXT;md5=${LLVMMD5SUM} \
5" 5"
6LICENSE = "NCSA" 6LICENSE = "NCSA"
7 7
8BASEURI ??= "${LLVM_GIT}/llvm-project-20170507;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH}" 8BASEURI ??= "${LLVM_GIT}/llvm-project;protocol=${LLVM_GIT_PROTOCOL};branch=${BRANCH}"
9SRC_URI = "\ 9SRC_URI = "\
10 ${BASEURI} \ 10 ${BASEURI} \
11 ${LLVMPATCHES} \ 11 ${LLVMPATCHES} \
diff --git a/recipes-devtools/clang/llvm-project-source.bb b/recipes-devtools/clang/llvm-project-source.bb
index a3133b2..78664c5 100644
--- a/recipes-devtools/clang/llvm-project-source.bb
+++ b/recipes-devtools/clang/llvm-project-source.bb
@@ -1,8 +1,8 @@
1# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com> 1# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4SUMMARY = "Flat monorepo imported from http://llvm.org/git/ (17 repos)" 4SUMMARY = "This is the canonical git mirror of the LLVM subversion repository."
5HOMEPAGE = "https://github.com/llvm-project/llvm-project-20170507" 5HOMEPAGE = "https://github.com/llvm/llvm-project"
6 6
7require llvm-project-source.inc 7require llvm-project-source.inc
8require clang.inc 8require clang.inc