summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-30 22:57:57 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 07:59:31 -0700
commit8d9d3ad0c3ea1ebd6568770dd4a686388db16168 (patch)
treeee5e70f598210a49f8879331bcb70b5690b99a73
parent7275ecf5de4b538080a846b5e415525e2f65507c (diff)
downloadmeta-clang-8d9d3ad0c3ea1ebd6568770dd4a686388db16168.tar.gz
Disable generating libcxx.so as script for native and nativesdk case
This confuses the libcxx build system and it tries to edit rpaths in .so files and fails miserably on libcxx.so if it is a linker script Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/libcxx_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 6bc86c7..10dd3c8 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -13,7 +13,7 @@ inherit cmake pythonnative
13PV .= "+git${SRCPV}" 13PV .= "+git${SRCPV}"
14 14
15DEPENDS += "ninja-native" 15DEPENDS += "ninja-native"
16BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx" 16BASEDEPENDS_remove_toolchain-clang = "libcxx"
17TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 17TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ "
18 18
19PACKAGECONFIG ??= "unwind" 19PACKAGECONFIG ??= "unwind"
@@ -56,6 +56,8 @@ EXTRA_OECMAKE += "\
56 ${S} \ 56 ${S} \
57" 57"
58 58
59EXTRA_OECMAKE_append_class-native = " -DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF"
60EXTRA_OECMAKE_append_class-nativesdk = " -DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF"
59EXTRA_OECMAKE_append_libc-musl = " -DLIBCXX_HAS_MUSL_LIBC=ON " 61EXTRA_OECMAKE_append_libc-musl = " -DLIBCXX_HAS_MUSL_LIBC=ON "
60 62
61do_compile() { 63do_compile() {