summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Romanek <aromanek.contractor@libertyglobal.com>2019-01-04 08:18:31 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-04 08:28:02 -0800
commit7933fd19fe1df357df0532d3983c10d014e8d5f6 (patch)
tree9e3f52e32ec71f50fc6e0ae2f257f129d15c07c8
parent0e03d228c95e7693538e951e9179ea7eab83c92c (diff)
downloadmeta-clang-7933fd19fe1df357df0532d3983c10d014e8d5f6.tar.gz
compiler-rt: Fix unintended dependencies concatenation
The error message was: >> Nothing PROVIDES 'ninja-nativeclang-native' (but virtual:nativesdk:/media/storage/romanek-adam/build-2018-12-17-clang/workspace/meta-clang/recipes-devtools/clang/compiler-rt_git.bb DEPENDS on or otherwise requires it)
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index b598040..f9eba8e 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -20,7 +20,7 @@ BASEDEPENDS_remove_toolchain-clang_class-target = "libcxx"
20TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ " 20TARGET_CXXFLAGS_remove_toolchain-clang = " -stdlib=libc++ "
21TUNE_CCARGS_remove = "-no-integrated-as" 21TUNE_CCARGS_remove = "-no-integrated-as"
22DEPENDS += "ninja-native" 22DEPENDS += "ninja-native"
23DEPENDS_append_class-nativesdk = "clang-native" 23DEPENDS_append_class-nativesdk = " clang-native"
24 24
25THUMB_TUNE_CCARGS = "" 25THUMB_TUNE_CCARGS = ""
26#TUNE_CCARGS += "-nostdlib" 26#TUNE_CCARGS += "-nostdlib"