summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Rosenkränzer <bernhard.rosenkraenzer.ext@huawei.com>2021-05-21 18:26:26 +0200
committerKhem Raj <raj.khem@gmail.com>2021-07-14 09:53:49 -0700
commitc8139a4dcb3560cfb70ad3965bd35289a7ff819e (patch)
treef3609248a8c42940ea63b432a086f884078dd468
parentaf99c02a85c264ab181b3cdeaf156de373de8b70 (diff)
downloadmeta-clang-c8139a4dcb3560cfb70ad3965bd35289a7ff819e.tar.gz
Dunfell compatibility
Signed-off-by: Bernhard Rosenkränzer <bernhard.rosenkraenzer.ext@huawei.com>
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const-1.31.1.patch177
-rw-r--r--recipes-core/busybox/busybox_1.31.1%.bbappend (renamed from recipes-core/busybox/busybox_1.33%.bbappend)2
3 files changed, 179 insertions, 2 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 14197c0..fc1d047 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
7BBFILE_COLLECTIONS += "clang-layer" 7BBFILE_COLLECTIONS += "clang-layer"
8BBFILE_PATTERN_clang-layer := "^${LAYERDIR}/" 8BBFILE_PATTERN_clang-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_clang-layer = "7" 9BBFILE_PRIORITY_clang-layer = "7"
10LAYERSERIES_COMPAT_clang-layer = "hardknott honister" 10LAYERSERIES_COMPAT_clang-layer = "dunfell hardknott honister"
11LAYERDEPENDS_clang-layer = "core" 11LAYERDEPENDS_clang-layer = "core"
12 12
13BBFILES_DYNAMIC += " \ 13BBFILES_DYNAMIC += " \
diff --git a/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const-1.31.1.patch b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const-1.31.1.patch
new file mode 100644
index 0000000..35a419b
--- /dev/null
+++ b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const-1.31.1.patch
@@ -0,0 +1,177 @@
1From d941b59087d34cb93053b638c066bf080122e7bb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 16 Jan 2019 22:39:24 -0800
4Subject: [PATCH] Turn ptr_to_globals and bb_errno to be non const
5
6writing to a const variable is undefined behavior
7
8This is undefined as per (C99 6.7.3 paragraph 5) see [1]
9
10errno and ptr_to_globals is written to in code, this fails with
11segfaults when compiled with clang
12
13unsigned FAST_FUNC bb_strtou(const char *arg, char **endp, int base)
14{
15 unsigned long v;
16 char *endptr;
17
18 if (!endp) endp = &endptr;
19 *endp = (char*) arg;
20
21 if (!isalnum(arg[0])) return ret_ERANGE();
22 errno = 0;
23 v = strtoul(arg, endp, base);
24 if (v > UINT_MAX) return ret_ERANGE();
25 return handle_errors(v, endp);
26 }
27
28without 'const' ( working code )
29
30Dump of assembler code for function bb_strtou:
31 0x0000555555568298 <+0>: push %rbx
32 0x0000555555568299 <+1>: sub $0x10,%rsp
33 0x000055555556829d <+5>: test %rsi,%rsi
34 0x00005555555682a0 <+8>: lea 0x8(%rsp),%rbx
35 0x00005555555682a5 <+13>: cmovne %rsi,%rbx
36 0x00005555555682a9 <+17>: mov %rdi,(%rbx)
37 0x00005555555682ac <+20>: mov (%rdi),%al
38 0x00005555555682ae <+22>: lea -0x30(%rax),%ecx
39 0x00005555555682b1 <+25>: cmp $0xa,%cl
40 0x00005555555682b4 <+28>: jb 0x5555555682be <bb_strtou+38>
41 0x00005555555682b6 <+30>: or $0x20,%al
42 0x00005555555682b8 <+32>: add $0x9f,%al
43 0x00005555555682ba <+34>: cmp $0x1a,%al
44 0x00005555555682bc <+36>: jae 0x5555555682dc <bb_strtou+68>
45 0x00005555555682be <+38>: mov 0x107da3(%rip),%rax # 0x555555670068 <bb_errno>
46=> 0x00005555555682c5 <+45>: movl $0x0,(%rax)
47 0x00005555555682cb <+51>: mov %rbx,%rsi
48 0x00005555555682ce <+54>: callq 0x555555564310 <strtoul@plt>
49 0x00005555555682d3 <+59>: mov %rax,%rcx
50 0x00005555555682d6 <+62>: shr $0x20,%rcx
51 0x00005555555682da <+66>: je 0x5555555682f0 <bb_strtou+88>
52 0x00005555555682dc <+68>: mov 0x107d85(%rip),%rax # 0x555555670068 <bb_errno>
53 0x00005555555682e3 <+75>: movl $0x22,(%rax)
54 0x00005555555682e9 <+81>: mov $0xffffffff,%eax
55 0x00005555555682ee <+86>: jmp 0x5555555682fb <bb_strtou+99>
56 0x00005555555682f0 <+88>: mov %rax,%rdi
57 0x00005555555682f3 <+91>: mov %rbx,%rsi
58 0x00005555555682f6 <+94>: callq 0x5555555681e8 <handle_errors>
59 0x00005555555682fb <+99>: add $0x10,%rsp
60 0x00005555555682ff <+103>: pop %rbx
61 0x0000555555568300 <+104>: retq
62
63here address of bb_errno is valid rax = 0x7ffff7cac6c0
64
65with 'const' ( non-working code )
66
67Dump of assembler code for function bb_strtou:
68 0x00005555555682a4 <+0>: push %r14
69 0x00005555555682a6 <+2>: push %rbx
70 0x00005555555682a7 <+3>: push %rax
71 0x00005555555682a8 <+4>: test %rsi,%rsi
72 0x00005555555682ab <+7>: mov %rsp,%rbx
73 0x00005555555682ae <+10>: cmovne %rsi,%rbx
74 0x00005555555682b2 <+14>: mov %rdi,(%rbx)
75 0x00005555555682b5 <+17>: mov (%rdi),%al
76 0x00005555555682b7 <+19>: lea -0x30(%rax),%ecx
77 0x00005555555682ba <+22>: cmp $0xa,%cl
78 0x00005555555682bd <+25>: jb 0x5555555682d6 <bb_strtou+50>
79 0x00005555555682bf <+27>: or $0x20,%al
80 0x00005555555682c1 <+29>: add $0x9f,%al
81 0x00005555555682c3 <+31>: cmp $0x1a,%al
82 0x00005555555682c5 <+33>: jb 0x5555555682d6 <bb_strtou+50>
83 0x00005555555682c7 <+35>: mov 0x107d9a(%rip),%rax # 0x555555670068 <bb_errno>
84 0x00005555555682ce <+42>: movl $0x22,(%rax)
85 0x00005555555682d4 <+48>: jmp 0x5555555682fc <bb_strtou+88>
86 0x00005555555682d6 <+50>: mov 0x107d8b(%rip),%r14 # 0x555555670068 <bb_errno>
87=> 0x00005555555682dd <+57>: movl $0x0,(%r14)
88 0x00005555555682e4 <+64>: mov %rbx,%rsi
89 0x00005555555682e7 <+67>: callq 0x555555564300 <strtoul@plt>
90 0x00005555555682ec <+72>: mov %rax,%rcx
91 0x00005555555682ef <+75>: shr $0x20,%rcx
92 0x00005555555682f3 <+79>: je 0x555555568303 <bb_strtou+95>
93 0x00005555555682f5 <+81>: movl $0x22,(%r14)
94 0x00005555555682fc <+88>: mov $0xffffffff,%eax
95 0x0000555555568301 <+93>: jmp 0x55555556830e <bb_strtou+106>
96 0x0000555555568303 <+95>: mov %rax,%rdi
97 0x0000555555568306 <+98>: mov %rbx,%rsi
98 0x0000555555568309 <+101>: callq 0x5555555681f4 <handle_errors>
99 0x000055555556830e <+106>: add $0x8,%rsp
100 0x0000555555568312 <+110>: pop %rbx
101 0x0000555555568313 <+111>: pop %r14
102 0x0000555555568315 <+113>: retq
103
104r14 is 0x0 and writing to this ofcourse ends up in segfault
105
106[1] https://bugs.llvm.org/show_bug.cgi?id=39919
107
108Signed-off-by: Khem Raj <raj.khem@gmail.com>
109[bero@lindev.ch: rebased to dunfell busybox]
110---
111 coreutils/test.c | 2 +-
112 include/libbb.h | 4 ++--
113 libbb/lineedit.c | 2 +-
114 shell/ash.c | 5 ++---
115 4 files changed, 6 insertions(+), 7 deletions(-)
116
117diff -up busybox-1.31.1/coreutils/test.c.omv~ busybox-1.31.1/coreutils/test.c
118--- busybox-1.31.1/coreutils/test.c.omv~ 2021-03-10 21:10:53.399954723 +0100
119+++ busybox-1.31.1/coreutils/test.c 2021-03-10 21:11:41.670409905 +0100
120@@ -401,7 +401,7 @@ struct test_statics {
121 };
122
123 /* See test_ptr_hack.c */
124-extern struct test_statics *const test_ptr_to_statics;
125+extern struct test_statics *test_ptr_to_statics;
126
127 #define S (*test_ptr_to_statics)
128 #define args (S.args )
129diff -up busybox-1.31.1/include/libbb.h.omv~ busybox-1.31.1/include/libbb.h
130--- busybox-1.31.1/include/libbb.h.omv~ 2021-03-10 21:11:09.916777141 +0100
131+++ busybox-1.31.1/include/libbb.h 2021-03-10 21:11:54.123860671 +0100
132@@ -341,7 +341,7 @@ struct BUG_off_t_size_is_misdetected {
133 #if defined(__GLIBC__)
134 /* glibc uses __errno_location() to get a ptr to errno */
135 /* We can just memorize it once - no multithreading in busybox :) */
136-extern int *const bb_errno;
137+extern int *bb_errno;
138 #undef errno
139 #define errno (*bb_errno)
140 #endif
141@@ -2109,7 +2109,7 @@ struct globals;
142 /* '*const' ptr makes gcc optimize code much better.
143 * Magic prevents ptr_to_globals from going into rodata.
144 * If you want to assign a value, use SET_PTR_TO_GLOBALS(x) */
145-extern struct globals *const ptr_to_globals;
146+extern struct globals *ptr_to_globals;
147 /* At least gcc 3.4.6 on mipsel system needs optimization barrier */
148 #define barrier() __asm__ __volatile__("":::"memory")
149 #define SET_PTR_TO_GLOBALS(x) do { \
150diff -up busybox-1.31.1/libbb/lineedit.c.omv~ busybox-1.31.1/libbb/lineedit.c
151--- busybox-1.31.1/libbb/lineedit.c.omv~ 2021-03-10 21:12:14.437385555 +0100
152+++ busybox-1.31.1/libbb/lineedit.c 2021-03-10 21:12:21.160782289 +0100
153@@ -181,7 +181,7 @@ struct lineedit_statics {
154 };
155
156 /* See lineedit_ptr_hack.c */
157-extern struct lineedit_statics *const lineedit_ptr_to_statics;
158+extern struct lineedit_statics *lineedit_ptr_to_statics;
159
160 #define S (*lineedit_ptr_to_statics)
161 #define state (S.state )
162diff -up busybox-1.31.1/shell/ash.c.omv~ busybox-1.31.1/shell/ash.c
163--- busybox-1.31.1/shell/ash.c.omv~ 2021-03-10 21:12:31.460879379 +0100
164+++ busybox-1.31.1/shell/ash.c 2021-03-10 21:13:24.368044942 +0100
165@@ -297,10 +297,8 @@ typedef long arith_t;
166 * set "-DBB_GLOBAL_CONST=''" in CONFIG_EXTRA_CFLAGS to disable
167 * this optimization.
168 */
169-#ifndef BB_GLOBAL_CONST
170-# define BB_GLOBAL_CONST const
171-#endif
172-
173+#undef BB_GLOBAL_CONST
174+#define BB_GLOBAL_CONST
175
176 /* ============ Hash table sizes. Configurable. */
177
diff --git a/recipes-core/busybox/busybox_1.33%.bbappend b/recipes-core/busybox/busybox_1.31.1%.bbappend
index f26df7e..726ee76 100644
--- a/recipes-core/busybox/busybox_1.33%.bbappend
+++ b/recipes-core/busybox/busybox_1.31.1%.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2SRC_URI_append_toolchain-clang = "\ 2SRC_URI_append_toolchain-clang = "\
3 file://0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch \ 3 file://0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const-1.31.1.patch \
4" 4"
5 5
6# networking/tls_pstm_sqr_comba.c:514:4: error: inline assembly requires more registers than available 6# networking/tls_pstm_sqr_comba.c:514:4: error: inline assembly requires more registers than available