summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-22 20:53:08 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-23 21:44:32 -0700
commit2c2724da06dd71e1f1d25d5894f88d36cfb26ee0 (patch)
tree1d685d36ff89b679bae881342ed39a08b43ddc55
parent23451d0e03455ba98e74941d20a37511c1c42aeb (diff)
downloadmeta-clang-2c2724da06dd71e1f1d25d5894f88d36cfb26ee0.tar.gz
openssh: Link with compiler-rt when using clang
clang -ftrapv, needs compiler-rt [1] [1] https://github.com/openssh/openssh-portable/blob/master/INSTALL#L7 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--conf/nonclangable.conf1
-rw-r--r--recipes-connectivity/openssh/openssh_%.bbappend3
2 files changed, 1 insertions, 3 deletions
diff --git a/conf/nonclangable.conf b/conf/nonclangable.conf
index 7c41469..f889df2 100644
--- a/conf/nonclangable.conf
+++ b/conf/nonclangable.conf
@@ -275,6 +275,7 @@ COMPILER_RT_pn-ruby_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
275COMPILER_RT_pn-python3_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 275COMPILER_RT_pn-python3_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
276COMPILER_RT_pn-m4_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 276COMPILER_RT_pn-m4_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
277COMPILER_RT_pn-cpio_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 277COMPILER_RT_pn-cpio_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
278COMPILER_RT_pn-openssh_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
278COMPILER_RT_pn-webkitgtk_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 279COMPILER_RT_pn-webkitgtk_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
279COMPILER_RT_pn-wpewebkit_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 280COMPILER_RT_pn-wpewebkit_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
280COMPILER_RT_pn-python3-numpy_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}" 281COMPILER_RT_pn-python3-numpy_toolchain-clang = "--rtlib=compiler-rt ${UNWINDLIB}"
diff --git a/recipes-connectivity/openssh/openssh_%.bbappend b/recipes-connectivity/openssh/openssh_%.bbappend
deleted file mode 100644
index 88966e5..0000000
--- a/recipes-connectivity/openssh/openssh_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1do_configure_prepend() {
2 sed -i -e '/-ftrapv/d' ${S}/configure.ac
3}