summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Dorniak <jaskij@gmail.com>2022-12-19 05:27:18 +0100
committerKhem Raj <raj.khem@gmail.com>2023-09-08 09:08:54 -0700
commitae8fd7c99f57bbfc8d1247a458710e3051b2fab0 (patch)
treed59135c7e038556ab32280eeada62db8e5a1523a
parent57ec3e04bda38a5bc82dfc5e370901d3f7b32995 (diff)
downloadmeta-clang-ae8fd7c99f57bbfc8d1247a458710e3051b2fab0.tar.gz
Fix OpenMP builds with thin LTO enabled.
When built with thin LTO enabled, LLVM produces object files containing LLVM IR, which ld can't understand. Since we're forcing the toolchain to clang anyway, let's also force using lld. Fixes GitHub #708 Signed-off-by: Jan Dorniak <jaskij@gmail.com> (cherry picked from commit bc8388c622c62cde24512d5b4473ede1f5710348)
-rw-r--r--recipes-devtools/clang/openmp_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index b1f1a8d..90b839c 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -12,6 +12,8 @@ TOOLCHAIN = "clang"
12 12
13LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" 13LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79"
14 14
15LDFLAGS:append = " -fuse-ld=lld"
16
15inherit cmake pkgconfig perlnative 17inherit cmake pkgconfig perlnative
16 18
17DEPENDS += "elfutils libffi clang" 19DEPENDS += "elfutils libffi clang"