summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-05-11 16:50:02 +0000
committerKhem Raj <raj.khem@gmail.com>2016-05-11 16:50:02 +0000
commitcf8622d2f253beeaf6735ada624477237c909379 (patch)
treeac185eaa648114645d33b8af9ca92832b1943aea
parent2b35ebd0cea1174d994f1d38bab1bd39d9ebf48d (diff)
downloadmeta-clang-cf8622d2f253beeaf6735ada624477237c909379.tar.gz
compiler-rt: Add missing deps on gcc runtime
Check for directory ${D}${libdir}/linux before operating on it Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index c5f0987..a9ce234 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -9,7 +9,8 @@ INHIBIT_DEFAULT_DEPS = "1"
9 9
10require clang.inc 10require clang.inc
11 11
12DEPENDS += "clang-cross-${TARGET_ARCH} virtual/${TARGET_PREFIX}libc-for-gcc" 12# libgcc gcc-runtime needed during configuring compiler-rt
13DEPENDS += "clang-cross-${TARGET_ARCH} virtual/${TARGET_PREFIX}libc-for-gcc libgcc gcc-runtime"
13 14
14PV .= "+git${SRCPV}" 15PV .= "+git${SRCPV}"
15 16
@@ -38,11 +39,13 @@ EXTRA_OECMAKE_append_libc-glibc = " -DCOMPILER_RT_BUILD_SANITIZERS=ON "
38EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF " 39EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF "
39 40
40do_install_append () { 41do_install_append () {
41 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f` 42 if [ -d ${D}${libdir}/linux ]; then
42 do 43 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f`
43 mv $f ${D}${libdir} 44 do
44 done 45 mv $f ${D}${libdir}
45 rmdir ${D}${libdir}/linux 46 done
47 rmdir ${D}${libdir}/linux
48 fi
46 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f` 49 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f`
47 do 50 do
48 mv $f ${D}${libdir} 51 mv $f ${D}${libdir}