summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2020-01-14 11:11:47 -0600
committerKhem Raj <raj.khem@gmail.com>2020-01-20 08:56:16 -0800
commit6892939b8c41582609711d6f6e73a03c421cac41 (patch)
tree9d63c33fd581fc67836ed53f5058f544fa2b767e
parentc946dfc62e84d3460c1bfd93f99b493f5ec3e085 (diff)
downloadmeta-clang-6892939b8c41582609711d6f6e73a03c421cac41.tar.gz
Make llvm CRT components optional
LLVM 9+ provides the crt startup components crtbegin.o and crtend.o, enabled by default. Make using these with the clang runtime optional. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 6543cda..4fd29b4 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -22,6 +22,9 @@ INHIBIT_DEFAULT_DEPS = "1"
22DEPENDS += "ninja-native clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc virtual/${TARGET_PREFIX}compilerlibs virtual/crypt" 22DEPENDS += "ninja-native clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc virtual/${TARGET_PREFIX}compilerlibs virtual/crypt"
23DEPENDS_append_class-nativesdk = " clang-native" 23DEPENDS_append_class-nativesdk = " clang-native"
24 24
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF"
27
25HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}" 28HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}"
26HF[vardepvalue] = "${HF}" 29HF[vardepvalue] = "${HF}"
27 30