summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-20 09:16:39 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-20 17:30:37 -0800
commit41fab212905a2047a277831ba9328465f242c27d (patch)
tree111ba1363a074838332510fee95eebdb801f7c10
parent4f602075e2996e0d2b7d22cbb6e22b68dee266cd (diff)
downloadmeta-clang-41fab212905a2047a277831ba9328465f242c27d.tar.gz
libcxx,compiler-rt: Use python3 during build
py2 is gone from oe-core Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb2
-rw-r--r--recipes-devtools/clang/libcxx_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 4fd29b4..9178031 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11inherit cmake pkgconfig pythonnative 11inherit cmake pkgconfig python3native
12 12
13 13
14LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a" 14LIC_FILES_CHKSUM = "file://compiler-rt/LICENSE.TXT;md5=d846d1d65baf322d4c485d6ee54e877a"
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 518682b..5bc864c 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11inherit cmake pythonnative 11inherit cmake python3native
12 12
13PACKAGECONFIG ??= "compiler-rt unwind exceptions" 13PACKAGECONFIG ??= "compiler-rt unwind exceptions"
14PACKAGECONFIG_riscv32 = "exceptions" 14PACKAGECONFIG_riscv32 = "exceptions"