summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Qingliang <niqingliang2003@gmail.com>2016-03-04 04:57:45 +0000
committerYi Qingliang <niqingliang2003@gmail.com>2016-03-04 04:57:45 +0000
commit39bcfb98c263dcdd3ce21fce7436f880f9122a1c (patch)
tree9d908f8820c97ab6e2d8185cde0902a3205014b4
parentf7c339e93c9563365e1397e2e505c0e1ada9130f (diff)
downloadmeta-clang-39bcfb98c263dcdd3ce21fce7436f880f9122a1c.tar.gz
remove empty directory when installing nativesdk
-rw-r--r--recipes-devtools/clang/clang_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index d6deb51..2903195 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -104,10 +104,11 @@ do_install_append_class-native () {
104 104
105do_install_append_class-nativesdk () { 105do_install_append_class-nativesdk () {
106 install -Dm 0755 ${B}/bin/clang-tblgen ${D}${bindir}/clang-tblgen 106 install -Dm 0755 ${B}/bin/clang-tblgen ${D}${bindir}/clang-tblgen
107 for f in `find ${D}${bindir} -executable -type f -not -type l`; do 107 for f in `find ${D}${bindir} -executable -type f -not -type l`; do
108 test -n "`file $f|grep -i ELF`" && ${STRIP} $f 108 test -n "`file $f|grep -i ELF`" && ${STRIP} $f
109 done 109 done
110 rm -rf ${D}${datadir}/llvm/cmake 110 rm -rf ${D}${datadir}/llvm/cmake
111 rm -rf ${D}${datadir}/llvm
111} 112}
112PACKAGE_DEBUG_SPLIT_STYLE_class-nativesdk = "debug-without-src" 113PACKAGE_DEBUG_SPLIT_STYLE_class-nativesdk = "debug-without-src"
113 114