summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-10 13:45:06 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-10 13:45:06 -0800
commit3743fe06938cd2a8384ad541ed11e4f085ade255 (patch)
treeb7dd07511d6108c115155a594bd59b2e7fe8fece
parent35b48ed99001ca14d9ee0f6f434182008bdc0c46 (diff)
downloadmeta-clang-3743fe06938cd2a8384ad541ed11e4f085ade255.tar.gz
openmp: Move the openmp patch to common clang
This ensures the common llvm sources are identical and can be re-used. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/common.inc1
-rw-r--r--recipes-devtools/clang/openmp_git.bb4
2 files changed, 1 insertions, 4 deletions
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
index b070428..c7f4073 100644
--- a/recipes-devtools/clang/common.inc
+++ b/recipes-devtools/clang/common.inc
@@ -36,6 +36,7 @@ SRC_URI = "\
36 file://0026-OpenCL-Fix-support-for-cl_khr_mipmap_image_writes.patch \ 36 file://0026-OpenCL-Fix-support-for-cl_khr_mipmap_image_writes.patch \
37 file://0027-InstCombine-visitBitCast-do-not-crash-on-weird-bitca.patch;patchdir=llvm \ 37 file://0027-InstCombine-visitBitCast-do-not-crash-on-weird-bitca.patch;patchdir=llvm \
38 file://0028-nfc-Fix-missing-include.patch \ 38 file://0028-nfc-Fix-missing-include.patch \
39 file://0029-OpenMP-link-fix.patch \
39" 40"
40 41
41# Fallback to no-PIE if not set 42# Fallback to no-PIE if not set
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index c8cda45..4c6be98 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -12,10 +12,6 @@ TOOLCHAIN = "clang"
12 12
13LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79" 13LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79"
14 14
15SRC_URI += "\
16 file://0029-OpenMP-link-fix.patch \
17"
18
19inherit cmake pkgconfig perlnative 15inherit cmake pkgconfig perlnative
20 16
21DEPENDS += "elfutils libffi" 17DEPENDS += "elfutils libffi"