summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-02-09 11:26:23 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-10 13:23:59 -0800
commit35b48ed99001ca14d9ee0f6f434182008bdc0c46 (patch)
treef3aabee308c073e574488c7a1dfdfa3ce252859a
parent5ac36e49ab0f4b9bc72a3c747841c1f9e54e640a (diff)
downloadmeta-clang-35b48ed99001ca14d9ee0f6f434182008bdc0c46.tar.gz
OpenMP Link fix
-fixes "version node not found for symbol omp_get_num_places_@@VERSION" Signed-off-by: Joel Winarske <joel.winarske@gmail.com>
-rw-r--r--recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch 26
-rw-r--r--recipes-devtools/clang/openmp_git.bb4
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch
new file mode 100644
index 0000000..3901268
--- /dev/null
+++ b/recipes-devtools/clang/clang/0029-OpenMP-link-fix.patch
@@ -0,0 +1,26 @@
1From 11bd98436bd7e99fb1fc2c07c150c71e2250a262 Mon Sep 17 00:00:00 2001
2From: Joel Winarske <joel.winarske@gmail.com>
3Date: Wed, 9 Feb 2022 11:11:55 -0800
4Subject: [PATCH] OpenMP link fix
5
6Signed-off-by: Joel Winarske <joel.winarske@gmail.com>
7---
8 openmp/runtime/src/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
12index 9f46b4bd4..3106e497d 100644
13--- a/openmp/runtime/src/CMakeLists.txt
14+++ b/openmp/runtime/src/CMakeLists.txt
15@@ -168,7 +168,7 @@ endif()
16
17 # Linking command will include libraries in LIBOMP_CONFIGURED_LIBFLAGS
18 libomp_get_libflags(LIBOMP_CONFIGURED_LIBFLAGS)
19-target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS})
20+target_link_libraries(omp ${LIBOMP_CONFIGURED_LIBFLAGS} ${CMAKE_DL_LIBS} "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exports_so.txt")
21
22 # Create *.inc before compiling any sources
23 # objects depend on : .inc files
24--
252.31.1
26
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb
index 4c6be98..c8cda45 100644
--- a/recipes-devtools/clang/openmp_git.bb
+++ b/recipes-devtools/clang/openmp_git.bb
@@ -12,6 +12,10 @@ TOOLCHAIN = "clang"
12 12
13LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79" 13LIC_FILES_CHKSUM = "file://openmp/LICENSE.txt;md5=d75288d1ce0450b28b8d58a284c09c79"
14 14
15SRC_URI += "\
16 file://0029-OpenMP-link-fix.patch \
17"
18
15inherit cmake pkgconfig perlnative 19inherit cmake pkgconfig perlnative
16 20
17DEPENDS += "elfutils libffi" 21DEPENDS += "elfutils libffi"