summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-26 12:32:52 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-09 07:54:23 -0700
commitd30bffae49cdabc777d62e87b56ddbcbc79acf06 (patch)
tree502a04cbeb882b872b82d52b89336fbf2a3c510b
parent209d0436707d59680151f03cd8146daacdbde487 (diff)
downloadmeta-clang-d30bffae49cdabc777d62e87b56ddbcbc79acf06.tar.gz
compiler-rt: Create lib/linux only if there is content to move to it
Fixes builds where there are no files inside ${D}${libdir}/linux but the empty dir is still created Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index bac47d7..3c98d34 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -65,17 +65,18 @@ do_install() {
65 65
66 66
67do_install_append () { 67do_install_append () {
68 install -d ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux
69 if [ -d ${D}${libdir}/linux ]; then 68 if [ -d ${D}${libdir}/linux ]; then
70 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f` 69 for f in `find ${D}${libdir}/linux -maxdepth 1 -type f`
71 do 70 do
72 mv $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux 71 install -D -m 0644 $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/lib/linux/`basename $f`
72 rm $f
73 done 73 done
74 rmdir ${D}${libdir}/linux 74 rmdir ${D}${libdir}/linux
75 fi 75 fi
76 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f` 76 for f in `find ${D}${exec_prefix} -maxdepth 1 -name '*.txt' -type f`
77 do 77 do
78 mv $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER} 78 install -D -m 0644 $f ${D}${libdir}/clang/${MAJOR_VER}.${MINOR_VER}.${PATCH_VER}/`basename $f`
79 rm $f
79 done 80 done
80} 81}
81 82