summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-13 00:29:01 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-13 00:29:27 -0700
commit5ffb0587e1f70c7bf7624cafa4b67902732f1e1e (patch)
tree693d383a63678a443f3648a03c96252b5aeef3b1
parentd07f50ec1abe557f30e192ad62fb787325ddec2b (diff)
downloadmeta-clang-5ffb0587e1f70c7bf7624cafa4b67902732f1e1e.tar.gz
compiler-rt: Disable sanitizers on mips32
They fail to compile error: 'assertion_failed__73' declared as an array with a negative size Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 7a63d99..ef07ce9 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -52,6 +52,7 @@ EXTRA_OECMAKE_append_class-nativesdk = "\
52" 52"
53 53
54EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF -DCOMPILER_RT_BUILD_XRAY=OFF " 54EXTRA_OECMAKE_append_libc-musl = " -DCOMPILER_RT_BUILD_SANITIZERS=OFF -DCOMPILER_RT_BUILD_XRAY=OFF "
55EXTRA_OECMAKE_append_mipsarch = "-DCOMPILER_RT_BUILD_SANITIZERS=OFF -DCOMPILER_RT_BUILD_XRAY=OFF "
55 56
56do_compile() { 57do_compile() {
57 ninja ${PARALLEL_MAKE} 58 ninja ${PARALLEL_MAKE}