summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/images/b2qt-embedded-image.bb50
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb28
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb14
3 files changed, 14 insertions, 78 deletions
diff --git a/recipes/images/b2qt-embedded-image.bb b/recipes/images/b2qt-embedded-image.bb
deleted file mode 100644
index 4a7f172..0000000
--- a/recipes/images/b2qt-embedded-image.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt on embedded Linux SDK image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34IMAGE_FEATURES += "\
35 package-management \
36 ssh-server-dropbear \
37 tools-debug \
38 debug-tweaks \
39 hwcodecs \
40 "
41
42inherit core-image
43inherit bootfs-image
44
45IMAGE_INSTALL += "\
46 packagegroup-b2qt-embedded-base \
47 packagegroup-b2qt-embedded-tools \
48 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
49 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
50 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 55394d6..b5bb73d 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -33,42 +33,24 @@ PR = "r0"
33 33
34inherit packagegroup 34inherit packagegroup
35 35
36MACHINE_EXTRA_INSTALL ?= ""
37
36RDEPENDS_${PN} = "\ 38RDEPENDS_${PN} = "\
37 kernel-modules \ 39 kernel-modules \
38 adbd \ 40 linux-firmware \
39 openssh-sftp-server \
40 openssl \
41 openssl-misc \ 41 openssl-misc \
42 libpng \
43 tiff \
44 libxslt \
45 icu \
46 freetype \
47 fontconfig \
48 liberation-fonts \
49 tslib \
50 tslib-calibrate \
51 alsa-utils-amixer \
52 hunspell \
53 ca-certificates \ 42 ca-certificates \
54 linux-firmware \ 43 liberation-fonts \
55 ttf-devanagari \ 44 ttf-devanagari \
56 ttf-opensans \ 45 ttf-opensans \
57 ttf-dejavu-common \ 46 ttf-dejavu-common \
58 ttf-dejavu-sans \ 47 ttf-dejavu-sans \
59 dbus-session-init \
60 otf-noto \ 48 otf-noto \
61 libmysqlclient \ 49 dbus-session-init \
62 libpq \
63 tzdata \ 50 tzdata \
64 tzdata-americas \ 51 tzdata-americas \
65 tzdata-asia \ 52 tzdata-asia \
66 tzdata-europe \ 53 tzdata-europe \
67 atk \
68 libevent \
69 ostree \
70 dracut \
71 connman \ 54 connman \
72 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \
73 ${MACHINE_EXTRA_INSTALL} \ 55 ${MACHINE_EXTRA_INSTALL} \
74 " 56 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index 17b278c..82f67b0 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -34,15 +34,19 @@ PR = "r0"
34inherit packagegroup 34inherit packagegroup
35 35
36RDEPENDS_${PN} = "\ 36RDEPENDS_${PN} = "\
37 ldd \ 37 adbd \
38 alsa-utils-amixer \
38 binutils \ 39 binutils \
39 binutils-symlinks \ 40 binutils-symlinks \
40 i2c-tools \
41 perf \
42 htop \
43 ntp \
44 connman-client \ 41 connman-client \
42 htop \
43 i2c-tools \
45 iproute2 \ 44 iproute2 \
45 ldd \
46 ntp \
47 openssh-sftp-server \
48 perf \
46 rsync \ 49 rsync \
50 tslib-calibrate \
47 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \ 51 ${@base_contains("DISTRO_FEATURES", "systemd", "systemd-analyze", "", d)} \
48 " 52 "