summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/systemd/systemd/usb-rndis.network5
-rw-r--r--recipes/systemd/systemd_%.bbappend10
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/systemd/systemd/usb-rndis.network b/recipes/systemd/systemd/usb-rndis.network
new file mode 100644
index 0000000..d529eeb
--- /dev/null
+++ b/recipes/systemd/systemd/usb-rndis.network
@@ -0,0 +1,5 @@
1[Match]
2Type=gadget
3
4[Network]
5LinkLocalAddressing=yes
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 0877135..4dce1b2 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -28,11 +28,19 @@
28############################################################################ 28############################################################################
29 29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch" 31SRC_URI += " \
32 file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch \
33 file://usb-rndis.network \
34"
35
36PACKAGECONFIG_append = " networkd"
32 37
33do_install_append() { 38do_install_append() {
34 # remove login from tty1 39 # remove login from tty1
35 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service 40 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
41 # set up link-local IPs for USB network interface
42 install -d ${D}${prefix}/lib/systemd/network/
43 install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/
36} 44}
37 45
38do_verify_patch_required() { 46do_verify_patch_required() {