summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rwxr-xr-xrecipes/busybox/busybox/busybox-ifplugd.sh32
-rwxr-xr-xrecipes/busybox/busybox/ifplugd.action6
-rw-r--r--recipes/busybox/busybox/network.cfg1
-rw-r--r--recipes/busybox/busybox_1.%.bbappend46
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb1
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb1
6 files changed, 2 insertions, 85 deletions
diff --git a/recipes/busybox/busybox/busybox-ifplugd.sh b/recipes/busybox/busybox/busybox-ifplugd.sh
deleted file mode 100755
index 9ea40a8..0000000
--- a/recipes/busybox/busybox/busybox-ifplugd.sh
+++ /dev/null
@@ -1,32 +0,0 @@
1#!/bin/sh
2DAEMON=/usr/sbin/ifplugd
3NAME=ifplugd
4DESC="Busybox IFPLUG Server"
5ARGS="-i eth0"
6
7test -f $DAEMON || exit 1
8
9set -e
10
11case "$1" in
12 start)
13 echo -n "starting $DESC: $NAME... "
14 /sbin/start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
15 echo "done."
16 ;;
17 stop)
18 echo -n "stopping $DESC: $NAME... "
19 /sbin/start-stop-daemon -K -n $NAME
20 echo "done."
21 ;;
22 restart)
23 echo "restarting $DESC: $NAME... "
24 $0 stop
25 $0 start
26 echo "done."
27 ;;
28 *)
29 echo "Usage: $0 {start|stop|restart}"
30 exit 1
31 ;;
32esac
diff --git a/recipes/busybox/busybox/ifplugd.action b/recipes/busybox/busybox/ifplugd.action
deleted file mode 100755
index 44fe040..0000000
--- a/recipes/busybox/busybox/ifplugd.action
+++ /dev/null
@@ -1,6 +0,0 @@
1#/bin/sh
2if [ "${2}" == "up" ]; then
3 ifup ${1}
4else
5 ifdown ${1}
6fi
diff --git a/recipes/busybox/busybox/network.cfg b/recipes/busybox/busybox/network.cfg
deleted file mode 100644
index f858907..0000000
--- a/recipes/busybox/busybox/network.cfg
+++ /dev/null
@@ -1 +0,0 @@
1CONFIG_IFPLUGD=y
diff --git a/recipes/busybox/busybox_1.%.bbappend b/recipes/busybox/busybox_1.%.bbappend
deleted file mode 100644
index 7a519c6..0000000
--- a/recipes/busybox/busybox_1.%.bbappend
+++ /dev/null
@@ -1,46 +0,0 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24SRC_URI += "\
25 file://network.cfg \
26 file://busybox-ifplugd.sh \
27 file://ifplugd.action \
28 "
29
30PACKAGES =+ "${PN}-ifplugd"
31FILES_${PN}-ifplugd = "\
32 ${sysconfdir}/init.d/busybox-ifplugd.sh \
33 ${sysconfdir}/etc/ifplugd/ifplugd.action \
34 "
35
36INITSCRIPT_PACKAGES += "${PN}-ifplugd"
37INITSCRIPT_NAME_${PN}-ifplugd = "busybox-ifplugd.sh"
38
39RRECOMMENDS_${PN} += "${PN}-ifplugd"
40
41do_install_append () {
42 install -m 0755 ${WORKDIR}/busybox-ifplugd.sh ${D}${sysconfdir}/init.d/
43
44 install -d ${D}${sysconfdir}/ifplugd
45 install -m 0755 ${WORKDIR}/ifplugd.action ${D}${sysconfdir}/ifplugd/
46}
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index a2d9c72..b6b9d11 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -62,6 +62,7 @@ RDEPENDS_${PN} = "\
62 libevent \ 62 libevent \
63 ostree \ 63 ostree \
64 dracut \ 64 dracut \
65 connman \
65 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \ 66 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \
66 ${MACHINE_EXTRA_INSTALL} \ 67 ${MACHINE_EXTRA_INSTALL} \
67 " 68 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
index 351a752..de36975 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -34,4 +34,5 @@ RDEPENDS_${PN} = "\
34 perf \ 34 perf \
35 htop \ 35 htop \
36 ntp \ 36 ntp \
37 connman-client \
37 " 38 "