summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/dracut/dracut_git.bbappend2
-rw-r--r--recipes/libgsystem/libgsystem.bb41
-rw-r--r--recipes/ostree/ostree.bb49
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb2
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb1
5 files changed, 95 insertions, 0 deletions
diff --git a/recipes/dracut/dracut_git.bbappend b/recipes/dracut/dracut_git.bbappend
new file mode 100644
index 0000000..479e407
--- /dev/null
+++ b/recipes/dracut/dracut_git.bbappend
@@ -0,0 +1,2 @@
1# Upstream recipe mistakenly depends on systemd, we remove that dependency here.
2RDEPENDS_${PN}_remove = "systemd"
diff --git a/recipes/libgsystem/libgsystem.bb b/recipes/libgsystem/libgsystem.bb
new file mode 100644
index 0000000..d2d1a0b
--- /dev/null
+++ b/recipes/libgsystem/libgsystem.bb
@@ -0,0 +1,41 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23SUMMARY = "LibGSystem is a GIO-based library, targeted primarily for use by operating system components."
24
25LICENSE = "LGPL-2.1"
26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
27
28inherit autotools pkgconfig
29
30SRC_URI = "gitsm://github.com/GNOME/libgsystem.git;tag=v2015.2;protocol=git"
31S = "${WORKDIR}/git"
32
33DEPENDS = "glib-2.0 attr libcap"
34
35do_configure_prepend() {
36 # Workaround a broken configure.ac. It should check first if GTK_DOC_CHECK
37 # macro is actually defined before trying to use it. For how-to see:
38 # https://developer.gnome.org/gtk-doc-manual/stable/settingup_autoconf.html.en
39 # We get a syntax error since we do not bundle gnome recipes that define this macro.
40 sed -i '/GTK_DOC_CHECK/d' ${S}/configure.ac
41}
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
new file mode 100644
index 0000000..1ba1504
--- /dev/null
+++ b/recipes/ostree/ostree.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2015 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees."
24
25LICENSE = "LGPL-2.1"
26LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
27
28inherit autotools pkgconfig
29
30SRC_URI = "git://github.com/GNOME/ostree.git;tag=v2015.7"
31S = "${WORKDIR}/git"
32
33DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
34
35EXTRA_OECONF = "--with-dracut --without-selinux --without-libarchive --with-grub2=no --enable-gtk-doc-html=no"
36
37do_configure_prepend() {
38 cd ${S}
39 # Update submodules and workaround bugs.
40 env NOCONFIGURE=1 ./autogen.sh
41 cd -
42}
43
44do_install_append() {
45 # Silence installed-vs-shipped error message. We provide our own dracut module.
46 # The only way to force OSTree to build necessary binaries is to pass "--with-dracut",
47 # this of course is a broken configure.ac logic.
48 rm -rf ${D}${libdir}/dracut/
49}
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
index 82e801b..a2d9c72 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -60,6 +60,8 @@ RDEPENDS_${PN} = "\
60 tzdata-europe \ 60 tzdata-europe \
61 atk \ 61 atk \
62 libevent \ 62 libevent \
63 ostree \
64 dracut \
63 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \ 65 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \
64 ${MACHINE_EXTRA_INSTALL} \ 66 ${MACHINE_EXTRA_INSTALL} \
65 " 67 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
index b31ea3f..59fa843 100644
--- a/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-toolchain-target.bb
@@ -50,6 +50,7 @@ RDEPENDS_${PN} += "\
50 libpq-dev \ 50 libpq-dev \
51 atk-dev \ 51 atk-dev \
52 libevent-dev \ 52 libevent-dev \
53 ostree-dev \
53 ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \ 54 ${@base_contains("DISTRO_FEATURES", "wayland", "libwayland-egl-mx6-dev libxkbcommon-dev libgbm-dev libdrm-dev", "", d)} \
54 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \ 55 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \
55 ${MACHINE_EXTRA_INSTALL_SDK} \ 56 ${MACHINE_EXTRA_INSTALL_SDK} \