summaryrefslogtreecommitdiffstats
path: root/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb')
-rw-r--r--recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb b/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb
new file mode 100644
index 0000000..752d8cb
--- /dev/null
+++ b/recipes/virtualbox/virtualbox-guest-additions_5.1.16.bb
@@ -0,0 +1,62 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Kernel drivers for the VirtualBox guest additions"
31LICENSE = "GPLv2"
32LIC_FILES_CHKSUM = "file://${WORKDIR}/VirtualBox-${PV}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
33
34inherit module
35
36MACHINE_KERNEL_PR_append = "a"
37PR = "${MACHINE_KERNEL_PR}"
38
39SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/VirtualBox-${PV}.tar.bz2"
40
41SRC_URI[md5sum] = "37ebbd51370841eed8ab80f2f38446d6"
42SRC_URI[sha256sum] = "78071c3172f3bd3c7981c352c3ae6c6a9c01f6ab24bc0aa7ec79f3528b2291a7"
43
44S = "${WORKDIR}/vbox"
45
46export KERN_DIR="${STAGING_KERNEL_DIR}"
47export KBUILD_VERBOSE="1"
48export BUILD_TARGET_ARCH="${ARCH}"
49
50do_compile_prepend() {
51 ${WORKDIR}/VirtualBox-${PV}/src/VBox/Additions/linux/export_modules ${WORKDIR}/vbox.tar.gz
52 tar xf ${WORKDIR}/vbox.tar.gz -C ${WORKDIR}/vbox
53}
54
55do_install() {
56 install -m 0755 -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
57 install -m 0644 vboxsf.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
58 install -m 0644 vboxguest.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
59 install -m 0644 vboxvideo.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/vbox
60}
61
62PKG_${PN} = "kernel-module-vbox"