summaryrefslogtreecommitdiffstats
path: root/recipes/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/systemd')
-rw-r--r--recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch27
-rw-r--r--recipes/systemd/systemd_%.bbappend33
2 files changed, 53 insertions, 7 deletions
diff --git a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
new file mode 100644
index 0000000..ed58b50
--- /dev/null
+++ b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
@@ -0,0 +1,27 @@
1From 6a7105e23d8be76094b90d814eab9135e2cc4b8a Mon Sep 17 00:00:00 2001
2From: Gatis Paeglis <gatis.paeglis@qt.io>
3Date: Tue, 21 Jun 2016 15:26:47 +0200
4Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
5 mounts too"
6
7This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
8---
9 src/core/mount.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/core/mount.c b/src/core/mount.c
13index fda4d65..3944232 100644
14--- a/src/core/mount.c
15+++ b/src/core/mount.c
16@@ -337,7 +337,7 @@ static int mount_add_device_links(Mount *m) {
17
18 assert(m);
19
20- p = get_mount_parameters(m);
21+ p = get_mount_parameters_fragment(m);
22 if (!p)
23 return 0;
24
25--
262.7.4
27
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 87b998b..0877135 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -1,25 +1,44 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += "file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch"
21 32
22do_install_append() { 33do_install_append() {
23 # remove login from tty1 34 # remove login from tty1
24 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service 35 rm -f ${D}${sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
25} 36}
37
38do_verify_patch_required() {
39 if [ -n "$(cat ${S}/NEWS | grep "CHANGES WITH 229")" ]; then
40 bbwarn "systemd: The 0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch patch is not required anymore."
41 fi
42}
43
44addtask do_verify_patch_required after do_fetch before do_configure