summaryrefslogtreecommitdiffstats
path: root/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb')
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb60
1 files changed, 0 insertions, 60 deletions
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
deleted file mode 100644
index 9f43fff..0000000
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Host packages for B2Qt on embedded Linux SDK"
31PR = "r0"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33
34inherit nativesdk packagegroup
35
36MACHINE_EXTRA_INSTALL_SDK_HOST ?= ""
37
38python __anonymous() {
39 overrides = d.getVar("OVERRIDES", True).split(":")
40 if "mingw32" not in overrides:
41 d.appendVar("OVERRIDES", ":linux")
42}
43
44RDEPENDS_${PN} = "\
45 nativesdk-gperf \
46 ${MACHINE_EXTRA_INSTALL_SDK_HOST} \
47 "
48
49RDEPENDS_${PN}_append_linux = "\
50 nativesdk-python3-modules \
51 nativesdk-python3-misc \
52 nativesdk-perl-modules \
53 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "nativesdk-wayland-dev", "", d)} \
54 "
55
56RDEPENDS_${PN}_append_mingw32 = "\
57 nativesdk-make \
58 nativesdk-libgcc \
59 nativesdk-libstdc++ \
60 "