summaryrefslogtreecommitdiffstats
path: root/recipes/ostree
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ostree')
-rw-r--r--recipes/ostree/ostree.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index 49060b6..8dac8a5 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -45,7 +45,8 @@ PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '',
45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 45PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
46 46
47SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 47SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
48FILES_${PN} += "${systemd_unitdir}/system/" 48FILES_${PN} += "${systemd_unitdir}/system/ \
49 ${libdir}/dracut/"
49 50
50EXTRA_OECONF = "--with-dracut \ 51EXTRA_OECONF = "--with-dracut \
51 --without-selinux \ 52 --without-selinux \
@@ -61,10 +62,3 @@ do_configure_prepend() {
61 env NOCONFIGURE=1 ./autogen.sh 62 env NOCONFIGURE=1 ./autogen.sh
62 cd - 63 cd -
63} 64}
64
65do_install_append() {
66 # Silence installed-vs-shipped error message. We provide our own dracut module.
67 # The only way to force OSTree to build necessary binaries is to pass "--with-dracut",
68 # this of course is a broken configure.ac logic.
69 rm -rf ${D}${libdir}/dracut/
70}