summaryrefslogtreecommitdiffstats
path: root/recipes/ostree
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ostree')
-rw-r--r--recipes/ostree/ostree.bb1
-rw-r--r--recipes/ostree/ostree/0005-Do-not-use-grub2-mkconfig.patch60
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index a0a1b8a..4dbafd5 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -32,6 +32,7 @@ SRC_URI = " \
32 file://0002-u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \ 32 file://0002-u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \
33 file://0003-Allow-updating-files-in-root-of-boot.patch \ 33 file://0003-Allow-updating-files-in-root-of-boot.patch \
34 file://0004-Mount-boot-partition.patch \ 34 file://0004-Mount-boot-partition.patch \
35 file://0005-Do-not-use-grub2-mkconfig.patch \
35 " 36 "
36 37
37SRCREV = "efdb4d8f443768e59529c299290bee8b1f8f93c3" 38SRCREV = "efdb4d8f443768e59529c299290bee8b1f8f93c3"
diff --git a/recipes/ostree/ostree/0005-Do-not-use-grub2-mkconfig.patch b/recipes/ostree/ostree/0005-Do-not-use-grub2-mkconfig.patch
new file mode 100644
index 0000000..1414ff7
--- /dev/null
+++ b/recipes/ostree/ostree/0005-Do-not-use-grub2-mkconfig.patch
@@ -0,0 +1,60 @@
1From b613d60319beffc861f5b1faa906d2ee0c685f52 Mon Sep 17 00:00:00 2001
2From: Gatis Paeglis <gatis.paeglis@theqtcompany.com>
3Date: Wed, 24 Feb 2016 18:12:27 +0100
4Subject: [PATCH] Do not use grub2-mkconfig.
5
6For details see: https://bugzilla.gnome.org/show_bug.cgi?id=762220
7---
8 src/libostree/ostree-bootloader-grub2.c | 12 +++++++++++-
9 1 file changed, 11 insertions(+), 1 deletion(-)
10
11diff --git a/src/libostree/ostree-bootloader-grub2.c b/src/libostree/ostree-bootloader-grub2.c
12index 1f89914..7cfb0dc 100644
13--- a/src/libostree/ostree-bootloader-grub2.c
14+++ b/src/libostree/ostree-bootloader-grub2.c
15@@ -282,6 +282,8 @@ grub2_child_setup (gpointer user_data)
16 }
17 }
18
19+#define OSTREE_NO_GRUB2_MKCONFIG
20+
21 static gboolean
22 _ostree_bootloader_grub2_write_config (OstreeBootloader *bootloader,
23 int bootversion,
24@@ -300,6 +302,7 @@ _ostree_bootloader_grub2_write_config (OstreeBootloader *bootloader,
25 g_autoptr(GFile) config_path_efi_dir = NULL;
26 g_autofree char *grub2_mkconfig_chroot = NULL;
27
28+#ifndef OSTREE_NO_GRUB2_MKCONFIG
29 if (ostree_sysroot_get_booted_deployment (self->sysroot) == NULL
30 && g_file_has_parent (self->sysroot->path, NULL))
31 {
32@@ -322,7 +325,7 @@ _ostree_bootloader_grub2_write_config (OstreeBootloader *bootloader,
33 tool_deployment_root = ostree_sysroot_get_deployment_directory (self->sysroot, tool_deployment);
34 grub2_mkconfig_chroot = g_file_get_path (tool_deployment_root);
35 }
36-
37+#endif
38 if (self->is_efi)
39 {
40 config_path_efi_dir = g_file_get_parent (self->config_path_efi);
41@@ -337,9 +340,16 @@ _ostree_bootloader_grub2_write_config (OstreeBootloader *bootloader,
42 bootversion);
43 }
44
45+#ifdef OSTREE_NO_GRUB2_MKCONFIG
46+ procctx = gs_subprocess_context_newv ("ostree-grub-generator", "-o",
47+ gs_file_get_path_cached (new_config_path),
48+ NULL);
49+#else
50 procctx = gs_subprocess_context_newv ("grub2-mkconfig", "-o",
51 gs_file_get_path_cached (new_config_path),
52 NULL);
53+#endif
54+
55 child_env = g_environ_setenv (child_env, "_OSTREE_GRUB2_BOOTVERSION", bootversion_str, TRUE);
56 /* We have to pass our state to the child */
57 if (self->is_efi)
58--
592.7.0
60