summaryrefslogtreecommitdiffstats
path: root/recipes/ostree/ostree.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ostree/ostree.bb')
-rw-r--r--recipes/ostree/ostree.bb86
1 files changed, 0 insertions, 86 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
deleted file mode 100644
index e4c8076..0000000
--- a/recipes/ostree/ostree.bb
+++ /dev/null
@@ -1,86 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Shared library with a reference command line tool for managing bootable, immutable, versioned filesystem trees."
31
32LICENSE = "LGPL-2.1"
33LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
34
35inherit autotools pkgconfig systemd
36
37SRC_URI = " \
38 git://github.com/ostreedev/ostree.git \
39 file://Mount-boot-partition.patch \
40 file://ostree-prepare-root-enabler-for-simpler-kernel-arg.patch \
41 file://deploy-add-karg-none-argument.patch \
42 file://Support-for-booting-without-initramfs.patch \
43 file://Allow-updating-files-in-the-boot-directory.patch \
44 file://u-boot-add-bootdir-to-the-generated-uEnv.txt.patch \
45 file://Create-firmware-convenience-symlinks.patch \
46 file://Print-pull-progress-also-when-not-on-console.patch \
47 file://Workaround-the-SIGCHLD-handler-issue.patch \
48 file://workaround-gtkdocize-configure-issue-in-autog.patch \
49 "
50
51SRCREV = "8ece4d6d51bdbe3e41ab318259276bb83e553aa0"
52
53S = "${WORKDIR}/git"
54
55DEPENDS = "glib-2.0 glib-2.0-native e2fsprogs gpgme attr libsoup-2.4 libassuan xz systemd"
56# Bash is needed by the shipped dracut module. This dracut module is used to generate initramfs image.
57# The production image do not require bash for proper working.
58RDEPENDS_${PN} += "bash"
59RRECOMMENDS_${PN} += "gnupg"
60
61PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
62PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
63
64SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
65FILES_${PN} += "${systemd_unitdir}/system/ \
66 ${libdir}/dracut/"
67
68EXTRA_OECONF = "--with-dracut \
69 --without-selinux \
70 --without-libarchive \
71 --with-builtin-grub2-mkconfig \
72 --enable-rofiles-fuse=no \
73 --enable-gtk-doc-html=no \
74 --enable-man=no \
75 --with-soup \
76 --with-static-prepare-root \
77 --disable-otmpfile \
78 --enable-introspection=no \
79 --enable-libsoup-client-certs"
80
81do_configure_prepend() {
82 cd ${S}
83 # Update submodules and workaround bugs.
84 env NOCONFIGURE=1 ./autogen.sh
85 cd -
86}