summaryrefslogtreecommitdiffstats
path: root/recipes/ostree/ostree.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ostree/ostree.bb')
-rw-r--r--recipes/ostree/ostree.bb45
1 files changed, 29 insertions, 16 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index 4dbafd5..6e79395 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -1,25 +1,33 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
21 29
22SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees." 30SUMMARY = "Shared library with a reference command line tool for managing bootable, immutable, versioned filesystem trees."
23 31
24LICENSE = "LGPL-2.1" 32LICENSE = "LGPL-2.1"
25LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 33LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
@@ -28,18 +36,21 @@ inherit autotools pkgconfig systemd
28 36
29SRC_URI = " \ 37SRC_URI = " \
30 git://github.com/GNOME/ostree.git \ 38 git://github.com/GNOME/ostree.git \
31 file://0001-Allow-updating-files-on-the-boot-partition.patch \ 39 file://Fix-enable_rofiles_fuse-no-build.patch \
32 file://0002-u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \ 40 file://Mount-boot-partition.patch \
33 file://0003-Allow-updating-files-in-root-of-boot.patch \ 41 file://Allow-updating-files-in-the-boot-directory.patch \
34 file://0004-Mount-boot-partition.patch \ 42 file://u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \
35 file://0005-Do-not-use-grub2-mkconfig.patch \ 43 file://Create-firmware-convenience-symlinks.patch \
36 " 44 "
37 45
38SRCREV = "efdb4d8f443768e59529c299290bee8b1f8f93c3" 46SRCREV = "v2016.5"
39 47
40S = "${WORKDIR}/git" 48S = "${WORKDIR}/git"
41 49
42DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz" 50DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz systemd"
51# Bash is needed by the shipped dracut module. This dracut module is used to generate initramfs image.
52# The production image do not require bash for proper working.
53RDEPENDS_${PN} += "bash"
43RRECOMMENDS_${PN} += "gnupg" 54RRECOMMENDS_${PN} += "gnupg"
44 55
45PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 56PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
@@ -52,8 +63,10 @@ FILES_${PN} += "${systemd_unitdir}/system/ \
52EXTRA_OECONF = "--with-dracut \ 63EXTRA_OECONF = "--with-dracut \
53 --without-selinux \ 64 --without-selinux \
54 --without-libarchive \ 65 --without-libarchive \
55 --with-grub2=no \ 66 --with-builtin-grub2-mkconfig \
67 --enable-rofiles-fuse=no \
56 --enable-gtk-doc-html=no \ 68 --enable-gtk-doc-html=no \
69 --enable-man=no \
57 --with-soup \ 70 --with-soup \
58 --enable-libsoup-client-certs" 71 --enable-libsoup-client-certs"
59 72