summaryrefslogtreecommitdiffstats
path: root/recipes/ostree/ostree.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ostree/ostree.bb')
-rw-r--r--recipes/ostree/ostree.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/recipes/ostree/ostree.bb b/recipes/ostree/ostree.bb
index 4dbafd5..2cfa4f4 100644
--- a/recipes/ostree/ostree.bb
+++ b/recipes/ostree/ostree.bb
@@ -19,7 +19,7 @@
19## 19##
20############################################################################## 20##############################################################################
21 21
22SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees." 22SUMMARY = "Shared library with a reference command line tool for managing bootable, immutable, versioned filesystem trees."
23 23
24LICENSE = "LGPL-2.1" 24LICENSE = "LGPL-2.1"
25LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 25LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
@@ -28,18 +28,21 @@ inherit autotools pkgconfig systemd
28 28
29SRC_URI = " \ 29SRC_URI = " \
30 git://github.com/GNOME/ostree.git \ 30 git://github.com/GNOME/ostree.git \
31 file://0001-Allow-updating-files-on-the-boot-partition.patch \ 31 file://Fix-enable_rofiles_fuse-no-build.patch \
32 file://0002-u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \ 32 file://Mount-boot-partition.patch \
33 file://0003-Allow-updating-files-in-root-of-boot.patch \ 33 file://Allow-updating-files-in-the-boot-directory.patch \
34 file://0004-Mount-boot-partition.patch \ 34 file://u-boot-Merge-ostree-s-and-systems-uEnv.txt.patch \
35 file://0005-Do-not-use-grub2-mkconfig.patch \ 35 file://Create-firmware-convenience-symlinks.patch \
36 " 36 "
37 37
38SRCREV = "efdb4d8f443768e59529c299290bee8b1f8f93c3" 38SRCREV = "v2016.5"
39 39
40S = "${WORKDIR}/git" 40S = "${WORKDIR}/git"
41 41
42DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz" 42DEPENDS = "glib-2.0 e2fsprogs gpgme attr libsoup-2.4 libgsystem libassuan xz"
43# Bash is needed by the shipped dracut module. This dracut module is used to generate initramfs image.
44# The production image do not require bash for proper working.
45RDEPENDS_${PN} += "bash"
43RRECOMMENDS_${PN} += "gnupg" 46RRECOMMENDS_${PN} += "gnupg"
44 47
45PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 48PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
@@ -52,8 +55,10 @@ FILES_${PN} += "${systemd_unitdir}/system/ \
52EXTRA_OECONF = "--with-dracut \ 55EXTRA_OECONF = "--with-dracut \
53 --without-selinux \ 56 --without-selinux \
54 --without-libarchive \ 57 --without-libarchive \
55 --with-grub2=no \ 58 --with-builtin-grub2-mkconfig \
59 --enable-rofiles-fuse=no \
56 --enable-gtk-doc-html=no \ 60 --enable-gtk-doc-html=no \
61 --enable-man=no \
57 --with-soup \ 62 --with-soup \
58 --enable-libsoup-client-certs" 63 --enable-libsoup-client-certs"
59 64