summaryrefslogtreecommitdiffstats
path: root/recipes/opengldummy/qtglesstream-dummy-client.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opengldummy/qtglesstream-dummy-client.bb')
-rw-r--r--recipes/opengldummy/qtglesstream-dummy-client.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes/opengldummy/qtglesstream-dummy-client.bb b/recipes/opengldummy/qtglesstream-dummy-client.bb
deleted file mode 100644
index 1d4e223..0000000
--- a/recipes/opengldummy/qtglesstream-dummy-client.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "QtGlesStream dummy client provides headers and a dummy library for EGL/GLES"
31SECTION = "devel"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
34
35PV = "1.0.0"
36SOLIBMAJOR = "1"
37SOLIBMINOR = "0"
38
39require opengldummy.inc
40
41inherit nopackages
42
43S = "${WORKDIR}"
44
45do_compile() {
46 ${CC} ${LDFLAGS} -DQGS_BUILD_CLIENT_DLL -fPIC -shared -Wl,-soname,libQtGlesStreamClient.so.${SOLIBMAJOR} \
47 -I${WORKDIR}/headers -o libQtGlesStreamClient.so.${PV} ${WORKDIR}/egl.cpp ${WORKDIR}/gles2.cpp
48}
49
50do_install_append() {
51 install -m 0755 -d ${D}${libdir}
52 install -m 0755 ${S}/libQtGlesStreamClient.so.${PV} ${D}${libdir}
53 ln -s libQtGlesStreamClient.so.${PV} ${D}${libdir}/libQtGlesStreamClient.so.${SOLIBMAJOR}.${SOLIBMINOR}
54 ln -s libQtGlesStreamClient.so.${PV} ${D}${libdir}/libQtGlesStreamClient.so.${SOLIBMAJOR}
55 ln -s libQtGlesStreamClient.so.${PV} ${D}${libdir}/libQtGlesStreamClient.so
56}