diff options
Diffstat (limited to 'recipes/mesa')
-rw-r--r-- | recipes/mesa/mesa_9.1.3.bb | 139 |
1 files changed, 0 insertions, 139 deletions
diff --git a/recipes/mesa/mesa_9.1.3.bb b/recipes/mesa/mesa_9.1.3.bb deleted file mode 100644 index 99c3a38..0000000 --- a/recipes/mesa/mesa_9.1.3.bb +++ /dev/null | |||
@@ -1,139 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | SUMMARY = "A free implementation of the OpenGL API" | ||
24 | DESCRIPTION = "Mesa is an open-source implementation of the OpenGL specification - \ | ||
25 | a system for rendering interactive 3D graphics. \ | ||
26 | A variety of device drivers allows Mesa to be used in many different environments \ | ||
27 | ranging from software emulation to complete hardware acceleration for modern GPUs. \ | ||
28 | Mesa is used as part of the overall Direct Rendering Infrastructure and X.org \ | ||
29 | environment." | ||
30 | |||
31 | HOMEPAGE = "http://mesa3d.org" | ||
32 | BUGTRACKER = "https://bugs.freedesktop.org" | ||
33 | SECTION = "x11" | ||
34 | LICENSE = "MIT" | ||
35 | LIC_FILES_CHKSUM = "file://docs/license.html;md5=42d77d95cba529a3637129be87d6555d" | ||
36 | |||
37 | INC_PR = "r9" | ||
38 | PE = "2" | ||
39 | |||
40 | export WANT_LLVM_RELEASE = "3.2" | ||
41 | |||
42 | DEPENDS = "expat makedepend-native flex-native bison-native llvm${WANT_LLVM_RELEASE}" | ||
43 | |||
44 | PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" | ||
45 | |||
46 | inherit autotools pkgconfig pythonnative | ||
47 | |||
48 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \ | ||
49 | file://EGL-Mutate-NativeDisplayType-depending-on-config.patch \ | ||
50 | file://fix-glsl-cross.patch \ | ||
51 | file://0001-configure-Avoid-use-of-AC_CHECK_FILE-for-cross-compi.patch \ | ||
52 | file://0001-llvmpipe-remove-the-power-of-two-sizeof-struct-cmd_b.patch \ | ||
53 | file://0001-fix-xlib-dependency-from-pipe-loader.patch \ | ||
54 | file://glapi.patch \ | ||
55 | " | ||
56 | |||
57 | SRC_URI[md5sum] = "952ccd03547ed72333b64e1746cf8ada" | ||
58 | SRC_URI[sha256sum] = "8d5dac2202d0355bff5cfd183582ec8167d1d1227b7bb7a669acecbeaa52d766" | ||
59 | |||
60 | S = "${WORKDIR}/Mesa-${PV}" | ||
61 | |||
62 | EXTRA_OECONF = " \ | ||
63 | --enable-opengl \ | ||
64 | --enable-gles2 \ | ||
65 | --enable-egl --with-egl-platforms=fbdev \ | ||
66 | --enable-gallium --enable-gallium-llvm --enable-gallium-egl --with-llvm-shared-libs --with-gallium-drivers="swrast" \ | ||
67 | --enable-shared-glapi \ | ||
68 | --disable-glx \ | ||
69 | --enable-dri --with-dri-drivers="" \ | ||
70 | --disable-gles1 \ | ||
71 | --disable-gles3 \ | ||
72 | --disable-openvg \ | ||
73 | " | ||
74 | |||
75 | # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2) | ||
76 | FULL_OPTIMIZATION_append = " -fno-omit-frame-pointer" | ||
77 | |||
78 | # Multiple virtual/gl providers being built breaks staging | ||
79 | EXCLUDE_FROM_WORLD = "1" | ||
80 | |||
81 | # Remove the mesa dependency on mesa-dev, as mesa is empty | ||
82 | RDEPENDS_${PN}-dev = "" | ||
83 | |||
84 | PACKAGES =+ "libegl-mesa libegl-mesa-dev \ | ||
85 | libglapi libglapi-dev \ | ||
86 | libgles2-mesa libgles2-mesa-dev \ | ||
87 | libegl-gallium \ | ||
88 | " | ||
89 | |||
90 | do_install_append () { | ||
91 | # Drivers never need libtool .la files | ||
92 | rm -f ${D}${libdir}/egl/*.la | ||
93 | rm -f ${D}${libdir}/gallium-pipe/*.la | ||
94 | } | ||
95 | |||
96 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
97 | # they don't get Debian-renamed (which would remove the -mesa suffix), and | ||
98 | # RPROVIDEs/RCONFLICTs on the generic libgl name. | ||
99 | python __anonymous() { | ||
100 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
101 | ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), | ||
102 | ("libgles3",)): | ||
103 | fullp = p[0] + "-mesa" | ||
104 | pkgs = " ".join(p) | ||
105 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
106 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
107 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
108 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
109 | |||
110 | # For -dev, the first element is both the Debian and original name | ||
111 | fullp += "-dev" | ||
112 | pkgs = p[0] + "-dev" | ||
113 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
114 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
115 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
116 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
117 | } | ||
118 | |||
119 | python mesa_populate_packages() { | ||
120 | pipe_drivers_root = os.path.join(d.getVar('libdir', True), "gallium-pipe") | ||
121 | do_split_packages(d, pipe_drivers_root, '^pipe_(.*)\.so$', 'mesa-driver-pipe-%s', 'Mesa %s pipe driver', extra_depends='') | ||
122 | } | ||
123 | |||
124 | PACKAGESPLITFUNCS_prepend = "mesa_populate_packages " | ||
125 | |||
126 | PACKAGES_DYNAMIC += "^mesa-driver-.*" | ||
127 | |||
128 | FILES_libegl-mesa = "${libdir}/libEGL.so.*" | ||
129 | FILES_libgles2-mesa = "${libdir}/libGLESv2.so.*" | ||
130 | FILES_libglapi = "${libdir}/libglapi.so.*" | ||
131 | FILES_libegl-gallium = "${libdir}/egl/egl_gallium.so* ${libdir}/egl/st_GL.so*" | ||
132 | |||
133 | FILES_libegl-mesa-dev = "${libdir}/libEGL.* ${includedir}/EGL ${includedir}/KHR ${libdir}/pkgconfig/egl.pc" | ||
134 | FILES_libglapi-dev = "${libdir}/libglapi.*" | ||
135 | FILES_libgles2-mesa-dev = "${libdir}/libGLESv2.* ${includedir}/GLES2 ${libdir}/pkgconfig/glesv2.pc" | ||
136 | |||
137 | FILES_${PN}-dbg += "${libdir}/egl/.debug/* ${libdir}/gallium-pipe/.debug" | ||
138 | |||
139 | |||