summaryrefslogtreecommitdiffstats
path: root/recipes/mesa/mesa/fix-glsl-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mesa/mesa/fix-glsl-cross.patch')
-rw-r--r--recipes/mesa/mesa/fix-glsl-cross.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/mesa/mesa/fix-glsl-cross.patch b/recipes/mesa/mesa/fix-glsl-cross.patch
new file mode 100644
index 0000000..34226ea
--- /dev/null
+++ b/recipes/mesa/mesa/fix-glsl-cross.patch
@@ -0,0 +1,43 @@
1The target libtool is used when building host binaries, which predictably
2doesn't work.
3
4Upstream-Status: Submitted (https://bugs.freedesktop.org/show_bug.cgi?id=44618)
5Signed-off-by: Jonathan Liu <net147@gmail.com>
6Signed-off-by: Ross Burton <ross.burton@intel.com>
7
8diff --git a/src/glsl/builtin_compiler/Makefile.am b/src/glsl/builtin_compiler/Makefile.am
9index e11a17f..8ebe0a2 100644
10--- a/src/glsl/builtin_compiler/Makefile.am
11+++ b/src/glsl/builtin_compiler/Makefile.am
12@@ -64,6 +64,8 @@ AM_CXXFLAGS = $(AM_CFLAGS)
13 include ../Makefile.sources
14
15 noinst_PROGRAMS = builtin_compiler
16+
17+if !CROSS_COMPILING
18 noinst_LTLIBRARIES = libglslcore.la libglcpp.la
19
20 libglcpp_la_SOURCES = \
21@@ -73,6 +75,7 @@ libglcpp_la_SOURCES = \
22 libglslcore_la_SOURCES = \
23 $(BUILTIN_COMPILER_GENERATED_CXX_FILES) \
24 $(LIBGLSL_FILES)
25+endif
26
27 builtin_compiler_SOURCES = \
28 $(top_srcdir)/src/mesa/main/hash_table.c \
29@@ -81,4 +84,14 @@ builtin_compiler_SOURCES = \
30 $(top_srcdir)/src/mesa/program/symbol_table.c \
31 $(BUILTIN_COMPILER_CXX_FILES) \
32 $(GLSL_COMPILER_CXX_FILES)
33+
34+if CROSS_COMPILING
35+builtin_compiler_SOURCES += \
36+ $(LIBGLCPP_GENERATED_FILES) \
37+ $(LIBGLCPP_FILES) \
38+ $(BUILTIN_COMPILER_GENERATED_CXX_FILES) \
39+ $(LIBGLSL_FILES)
40+builtin_compiler_CPPFLAGS = $(AM_CPPFLAGS)
41+else
42 builtin_compiler_LDADD = libglslcore.la libglcpp.la
43+endif