summaryrefslogtreecommitdiffstats
path: root/recipes/libgsystem/libgsystem.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgsystem/libgsystem.bb')
-rw-r--r--recipes/libgsystem/libgsystem.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/recipes/libgsystem/libgsystem.bb b/recipes/libgsystem/libgsystem.bb
deleted file mode 100644
index 0e14055..0000000
--- a/recipes/libgsystem/libgsystem.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "LibGSystem is a GIO-based library, targeted primarily for use by operating system components."
31
32LICENSE = "LGPL-2.1"
33LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
34
35inherit autotools pkgconfig
36
37SRC_URI = "gitsm://github.com/GNOME/libgsystem.git;protocol=git"
38SRCREV = "86c24c181ec6c3ec334a39145efc022c3e744929"
39
40S = "${WORKDIR}/git"
41
42DEPENDS = "glib-2.0 attr libcap"
43
44do_configure_prepend() {
45 # Workaround a broken configure.ac. It should check first if GTK_DOC_CHECK
46 # macro is actually defined before trying to use it. For how-to see:
47 # https://developer.gnome.org/gtk-doc-manual/stable/settingup_autoconf.html.en
48 # We get a syntax error since we do not bundle gnome recipes that define this macro.
49 sed -i '/GTK_DOC_CHECK/d' ${S}/configure.ac
50}