diff options
Diffstat (limited to 'recipes/fonts')
-rw-r--r-- | recipes/fonts/ttf-devanagari_2.94.0.bb | 24 | ||||
-rw-r--r-- | recipes/fonts/ttf-opensans.bb | 21 |
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb new file mode 100644 index 0000000..69e66c8 --- /dev/null +++ b/recipes/fonts/ttf-devanagari_2.94.0.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Lohit Devanagari Fonts" | ||
2 | SECTION = "fonts" | ||
3 | HOMEPAGE = "https://fedorahosted.org/lohit/" | ||
4 | LICENSE = "OFL-1.1" | ||
5 | LIC_FILES_CHKSUM = "file://${WORKDIR}/lohit-devanagari-ttf-${PV}/OFL.txt;md5=7dfa0a236dc535ad2d2548e6170c4402" | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | inherit allarch fontcache | ||
10 | |||
11 | SRC_URI = "https://fedorahosted.org/releases/l/o/lohit/lohit-devanagari-ttf-${PV}.tar.gz" | ||
12 | |||
13 | SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8" | ||
14 | SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353" | ||
15 | |||
16 | do_install() { | ||
17 | install -m 0644 -d ${D}${datadir}/fonts/truetype/lohit | ||
18 | install -m 0644 -d ${D}${sysconfdir}/fonts/conf.d/ | ||
19 | install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/66-lohit-devanagari.conf ${D}${sysconfdir}/fonts/conf.d/ | ||
20 | install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/Lohit-Devanagari.ttf ${D}${datadir}/fonts/truetype/lohit | ||
21 | } | ||
22 | |||
23 | PACKAGES = "${PN}" | ||
24 | FILES_${PN} += "${datadir}/fonts/truetype/lohit" | ||
diff --git a/recipes/fonts/ttf-opensans.bb b/recipes/fonts/ttf-opensans.bb new file mode 100644 index 0000000..ad40b81 --- /dev/null +++ b/recipes/fonts/ttf-opensans.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Open Sans Fonts" | ||
2 | SECTION = "fonts" | ||
3 | HOMEPAGE = "https://www.google.com/fonts" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE.txt;md5=d273d63619c9aeaf15cdaf76422c4f87" | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | inherit allarch fontcache | ||
10 | |||
11 | SRC_URI = "https://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ;downloadfilename=Open_Sans.zip" | ||
12 | # Google packs fonts package on demand which results in unpredictable md5sum, so disable checksum check | ||
13 | BB_STRICT_CHECKSUM = "" | ||
14 | |||
15 | do_install() { | ||
16 | install -m 0644 -d ${D}${datadir}/fonts/truetype/opensans | ||
17 | install -m 0644 ${WORKDIR}/*.ttf ${D}${datadir}/fonts/truetype/opensans | ||
18 | } | ||
19 | |||
20 | PACKAGES = "${PN}" | ||
21 | FILES_${PN} += "${datadir}/fonts/truetype/opensans" | ||