summaryrefslogtreecommitdiffstats
path: root/recipes/fonts/ttf-freefont_20120503.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fonts/ttf-freefont_20120503.bb')
-rw-r--r--recipes/fonts/ttf-freefont_20120503.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-freefont_20120503.bb b/recipes/fonts/ttf-freefont_20120503.bb
new file mode 100644
index 0000000..abf9562
--- /dev/null
+++ b/recipes/fonts/ttf-freefont_20120503.bb
@@ -0,0 +1,49 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "GNU FreeFont is a free family of scalable outline fonts"
31HOMEPAGE = "http://savannah.gnu.org/projects/freefont"
32LICENSE = "GPLv3"
33LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
34
35require recipes-graphics/ttf-fonts/ttf.inc
36
37inherit allarch fontcache
38
39S = "${WORKDIR}/freefont-${PV}"
40
41SRC_URI = "http://ftp.gnu.org/gnu/freefont/freefont-ttf-${PV}.zip"
42
43SRC_URI[md5sum] = "879b76d2e3c8003d567b555743f39154"
44SRC_URI[sha256sum] = "7c85baf1bf82a1a1845d1322112bc6ca982221b484e3b3925022e25b5cae89af"
45
46PACKAGES = "${PN}-sans ${PN}-mono ${PN}-serif"
47FILES_${PN}-sans = "${datadir}/fonts/truetype/FreeSans*.ttf"
48FILES_${PN}-mono = "${datadir}/fonts/truetype/FreeMono*.ttf"
49FILES_${PN}-serif = "${datadir}/fonts/truetype/FreeSerif*.ttf"