summaryrefslogtreecommitdiffstats
path: root/recipes/fonts/ttf-devanagari_2.94.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fonts/ttf-devanagari_2.94.0.bb')
-rw-r--r--recipes/fonts/ttf-devanagari_2.94.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/fonts/ttf-devanagari_2.94.0.bb b/recipes/fonts/ttf-devanagari_2.94.0.bb
new file mode 100644
index 0000000..69e66c8
--- /dev/null
+++ b/recipes/fonts/ttf-devanagari_2.94.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Lohit Devanagari Fonts"
2SECTION = "fonts"
3HOMEPAGE = "https://fedorahosted.org/lohit/"
4LICENSE = "OFL-1.1"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/lohit-devanagari-ttf-${PV}/OFL.txt;md5=7dfa0a236dc535ad2d2548e6170c4402"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9inherit allarch fontcache
10
11SRC_URI = "https://fedorahosted.org/releases/l/o/lohit/lohit-devanagari-ttf-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "57527ee536a18b443cf786d4b8fd5ec8"
14SRC_URI[sha256sum] = "a6618aeb1d25df46d3c22e528c38ea1d1147654e19904497a1e97f4684c55353"
15
16do_install() {
17 install -m 0644 -d ${D}${datadir}/fonts/truetype/lohit
18 install -m 0644 -d ${D}${sysconfdir}/fonts/conf.d/
19 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/66-lohit-devanagari.conf ${D}${sysconfdir}/fonts/conf.d/
20 install -m 0644 ${WORKDIR}/lohit-devanagari-ttf-${PV}/Lohit-Devanagari.ttf ${D}${datadir}/fonts/truetype/lohit
21}
22
23PACKAGES = "${PN}"
24FILES_${PN} += "${datadir}/fonts/truetype/lohit"