summaryrefslogtreecommitdiffstats
path: root/recipes/fonts/otf-noto_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fonts/otf-noto_git.bb')
-rw-r--r--recipes/fonts/otf-noto_git.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/fonts/otf-noto_git.bb b/recipes/fonts/otf-noto_git.bb
new file mode 100644
index 0000000..3be53c2
--- /dev/null
+++ b/recipes/fonts/otf-noto_git.bb
@@ -0,0 +1,53 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30SUMMARY = "Noto Sans CJK"
31SECTION = "fonts"
32HOMEPAGE = "http://www.google.com/get/noto"
33LICENSE = "OFL-1.1"
34LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=55719faa0112708e946b820b24b14097"
35
36INHIBIT_DEFAULT_DEPS = "1"
37
38inherit allarch fontcache
39
40PV = "1.004"
41SRC_URI = "git://github.com/googlei18n/noto-cjk.git"
42SRCREV = "40d9f5b179a59a06b98373c76bdc3e2119e4e6b2"
43
44S = "${WORKDIR}/git"
45
46do_install() {
47 install -m 0755 -d ${D}${datadir}/fonts/otf/noto
48 install -m 0644 ${S}/NotoSansCJKsc-*.otf ${D}${datadir}/fonts/otf/noto
49 install -m 0644 ${S}/NotoSansMonoCJKsc-*.otf ${D}${datadir}/fonts/otf/noto
50}
51
52PACKAGES = "${PN}"
53FILES_${PN} += "${datadir}/fonts/otf/noto"