summaryrefslogtreecommitdiffstats
path: root/recipes/adbd/adbd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/adbd/adbd.bb')
-rw-r--r--recipes/adbd/adbd.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index 74d6a8a..89aa4ce 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -24,23 +24,23 @@ DESCRIPTION = "Android Debug Bridge Daemon"
24HOMEPAGE = "http://developer.android.com/tools/help/adb.html" 24HOMEPAGE = "http://developer.android.com/tools/help/adb.html"
25SECTION = "devel" 25SECTION = "devel"
26LICENSE = "Apache-2.0" 26LICENSE = "Apache-2.0"
27LIC_FILES_CHKSUM = "file://NOTICE;md5=2ddb23e63b1f9c3c46aaa4195f819a6d" 27LIC_FILES_CHKSUM = "file://adb/NOTICE;md5=2ddb23e63b1f9c3c46aaa4195f819a6d"
28 28
29PV = "android-4.2.2_r1.2" 29PV = "android-5.0.1_r1"
30PR = "r0" 30PR = "r0"
31SRCREV = "${PV}" 31SRCREV = "${PV}"
32 32
33RRECOMMENDS_${PN} += "kernel-module-g-ffs" 33RRECOMMENDS_${PN} += "kernel-module-g-ffs"
34DEPENDS = "openssl" 34DEPENDS = "openssl"
35 35
36SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https \ 36SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https;branch=lollipop-release;name=core \
37 file://adbd.patch;striplevel=2 \ 37 file://adbd.patch \
38 file://Makefile.adbd \ 38 file://Makefile.adbd \
39 file://adb-init \ 39 file://adb-init \
40 file://defaults \ 40 file://defaults \
41 " 41 "
42 42
43S = "${WORKDIR}/git/adb" 43S = "${WORKDIR}/git"
44 44
45FILES_${PN} += "${bindir}/adbd" 45FILES_${PN} += "${bindir}/adbd"
46 46
@@ -51,7 +51,7 @@ do_configure() {
51} 51}
52 52
53do_compile() { 53do_compile() {
54 make -f ${WORKDIR}/Makefile.adbd 54 make -f ${WORKDIR}/Makefile.adbd -C adb
55} 55}
56 56
57do_install() { 57do_install() {