diff options
Diffstat (limited to 'recipes-qt/qt5/qtvirtualkeyboard_git.bb')
-rw-r--r-- | recipes-qt/qt5/qtvirtualkeyboard_git.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb new file mode 100644 index 0000000..ef78418 --- /dev/null +++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | ############################################################################## | ||
2 | ## | ||
3 | ## Copyright (C) 2016 The Qt Company Ltd. | ||
4 | ## Contact: http://www.qt.io/licensing/ | ||
5 | ## | ||
6 | ## This file is part of the Boot to Qt meta layer. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE:COMM$ | ||
9 | ## | ||
10 | ## Commercial License Usage | ||
11 | ## Licensees holding valid commercial Qt licenses may use this file in | ||
12 | ## accordance with the commercial license agreement provided with the | ||
13 | ## Software or, alternatively, in accordance with the terms contained in | ||
14 | ## a written agreement between you and The Qt Company. For licensing terms | ||
15 | ## and conditions see http://www.qt.io/terms-conditions. For further | ||
16 | ## information use the contact form at http://www.qt.io/contact-us. | ||
17 | ## | ||
18 | ## $QT_END_LICENSE$ | ||
19 | ## | ||
20 | ############################################################################## | ||
21 | |||
22 | DESCRIPTION = "Qt Virtual Keyboard" | ||
23 | LICENSE = "QtEnterprise" | ||
24 | LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=8913d0b71519756d2e83db02b9629bbd;beginline=1;endline=17" | ||
25 | |||
26 | inherit qt5-module qtquickcompiler | ||
27 | require recipes-qt/qt5/qt5-git.inc | ||
28 | |||
29 | SRCREV = "68c30e00b0d9850643611d5ba9c29a247ccd44ec" | ||
30 | |||
31 | DEPENDS = "qtbase qtdeclarative qtsvg hunspell" | ||
32 | |||
33 | PACKAGECONFIG ?= "lipi-toolkit lang-all" | ||
34 | PACKAGECONFIG[t9write] = "CONFIG+=t9write" | ||
35 | PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit" | ||
36 | PACKAGECONFIG[lang-all] = "CONFIG+=lang-all" | ||
37 | PACKAGECONFIG[lang-ar_AR] = "CONFIG+=lang-ar_AR" | ||
38 | PACKAGECONFIG[lang-da_DK] = "CONFIG+=lang-da_DK" | ||
39 | PACKAGECONFIG[lang-de_DE] = "CONFIG+=lang-de_DE" | ||
40 | PACKAGECONFIG[lang-en_GB] = "CONFIG+=lang-en_GB" | ||
41 | PACKAGECONFIG[lang-es_ES] = "CONFIG+=lang-es_ES" | ||
42 | PACKAGECONFIG[lang-fa_FA] = "CONFIG+=lang-fa_FA" | ||
43 | PACKAGECONFIG[lang-fi_FI] = "CONFIG+=lang-fi_FI" | ||
44 | PACKAGECONFIG[lang-fr_FR] = "CONFIG+=lang-fr_FR" | ||
45 | PACKAGECONFIG[lang-hi_IN] = "CONFIG+=lang-hi_IN" | ||
46 | PACKAGECONFIG[lang-it_IT] = "CONFIG+=lang-it_IT" | ||
47 | PACKAGECONFIG[lang-ja_JP] = "CONFIG+=lang-ja_JP" | ||
48 | PACKAGECONFIG[lang-ko_KR] = "CONFIG+=lang-ko_KR" | ||
49 | PACKAGECONFIG[lang-nb_NO] = "CONFIG+=lang-nb_NO" | ||
50 | PACKAGECONFIG[lang-pl_PL] = "CONFIG+=lang-pl_PL" | ||
51 | PACKAGECONFIG[lang-pt_PT] = "CONFIG+=lang-pt_PT" | ||
52 | PACKAGECONFIG[lang-ru_RU] = "CONFIG+=lang-ru_RU" | ||
53 | PACKAGECONFIG[lang-sv_SE] = "CONFIG+=lang-sv_SE" | ||
54 | PACKAGECONFIG[lang-zh_CN] = "CONFIG+=lang-zh_CN" | ||
55 | PACKAGECONFIG[lang-zh_TW] = "CONFIG+=lang-zh_TW" | ||
56 | |||
57 | EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}" | ||
58 | EXTRA_QMAKEVARS_PRE += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'CONFIG+=disable-desktop', d)}" | ||
59 | |||
60 | PACKAGES += "${PN}-dictionaries" | ||
61 | RRECOMMENDS_${PN} += "${PN}-dictionaries" | ||
62 | FILES_${PN}-dictionaries = "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/*/*.dat" | ||
63 | |||
64 | FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit" | ||
65 | FILES_${PN}-dbg += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit/lib/.debug" | ||
66 | INSANE_SKIP_${PN} += "libdir" | ||
67 | INSANE_SKIP_${PN}-dbg += "libdir" | ||