summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtvirtualkeyboard_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtvirtualkeyboard_git.bb')
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
deleted file mode 100644
index e7ab947..0000000
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22DESCRIPTION = "Qt Virtual Keyboard"
23LICENSE = "QtEnterprise"
24LIC_FILES_CHKSUM = "file://src/virtualkeyboard/plugin.cpp;md5=8913d0b71519756d2e83db02b9629bbd;beginline=1;endline=17"
25
26inherit qt5-module qtquickcompiler
27require recipes-qt/qt5/qt5-git.inc
28
29SRCREV = "13a199e6e2c5f27b0f12eff380df4f0c0d156e6e"
30
31DEPENDS = "qtbase qtdeclarative qtsvg hunspell"
32
33PACKAGECONFIG ?= "lipi-toolkit lang-all"
34PACKAGECONFIG[t9write] = "CONFIG+=t9write"
35PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit"
36PACKAGECONFIG[lang-all] = "CONFIG+=lang-all"
37PACKAGECONFIG[lang-ar_AR] = "CONFIG+=lang-ar_AR"
38PACKAGECONFIG[lang-da_DK] = "CONFIG+=lang-da_DK"
39PACKAGECONFIG[lang-de_DE] = "CONFIG+=lang-de_DE"
40PACKAGECONFIG[lang-en_GB] = "CONFIG+=lang-en_GB"
41PACKAGECONFIG[lang-es_ES] = "CONFIG+=lang-es_ES"
42PACKAGECONFIG[lang-fa_FA] = "CONFIG+=lang-fa_FA"
43PACKAGECONFIG[lang-fi_FI] = "CONFIG+=lang-fi_FI"
44PACKAGECONFIG[lang-fr_FR] = "CONFIG+=lang-fr_FR"
45PACKAGECONFIG[lang-hi_IN] = "CONFIG+=lang-hi_IN"
46PACKAGECONFIG[lang-it_IT] = "CONFIG+=lang-it_IT"
47PACKAGECONFIG[lang-ja_JP] = "CONFIG+=lang-ja_JP"
48PACKAGECONFIG[lang-ko_KR] = "CONFIG+=lang-ko_KR"
49PACKAGECONFIG[lang-nb_NO] = "CONFIG+=lang-nb_NO"
50PACKAGECONFIG[lang-pl_PL] = "CONFIG+=lang-pl_PL"
51PACKAGECONFIG[lang-pt_PT] = "CONFIG+=lang-pt_PT"
52PACKAGECONFIG[lang-ru_RU] = "CONFIG+=lang-ru_RU"
53PACKAGECONFIG[lang-sv_SE] = "CONFIG+=lang-sv_SE"
54PACKAGECONFIG[lang-zh_CN] = "CONFIG+=lang-zh_CN"
55PACKAGECONFIG[lang-zh_TW] = "CONFIG+=lang-zh_TW"
56
57EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}"
58EXTRA_QMAKEVARS_PRE += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'CONFIG+=disable-desktop', d)}"
59
60PACKAGES += "${PN}-dictionaries"
61RRECOMMENDS_${PN} += "${PN}-dictionaries"
62FILES_${PN}-dictionaries = "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/*/*.dat"
63
64FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
65FILES_${PN}-dbg += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit/lib/.debug"
66INSANE_SKIP_${PN} += "libdir"
67INSANE_SKIP_${PN}-dbg += "libdir"