summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtquickcompiler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtquickcompiler_git.bb')
-rw-r--r--recipes-qt/qt5/qtquickcompiler_git.bb29
1 files changed, 18 insertions, 11 deletions
diff --git a/recipes-qt/qt5/qtquickcompiler_git.bb b/recipes-qt/qt5/qtquickcompiler_git.bb
index e0091b4..4d0fb6a 100644
--- a/recipes-qt/qt5/qtquickcompiler_git.bb
+++ b/recipes-qt/qt5/qtquickcompiler_git.bb
@@ -1,36 +1,43 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
21 29
22DESCRIPTION = "Qt Quick Compiler" 30DESCRIPTION = "Qt Quick Compiler"
23LICENSE = "QtEnterprise" 31LICENSE = "The-Qt-Company-DCLA-2.1"
24LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17" 32LIC_FILES_CHKSUM = "file://compiler/qtquickcompiler.h;md5=02f6307ab0d6c4bd38a1540f16ea705d;beginline=1;endline=17"
25 33
26inherit qt5-module 34inherit qt5-module
27 35
28SRC_URI = " \ 36SRC_URI = " \
29 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \ 37 git://codereview.qt-project.org/qt/tqtc-qmlcompiler;nobranch=1;protocol=ssh \
30 " 38 "
31 39
32SRCREV = "382935b1c5c93fba9ff2f25b74ec6a5337ec62d0" 40SRCREV = "033370939c8d969bfcb529745f643ee5d8a08790"
33BRANCH = "5.6"
34 41
35S = "${WORKDIR}/git" 42S = "${WORKDIR}/git"
36 43