summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons/qtglesstream.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5-addons/qtglesstream.bb')
-rw-r--r--recipes-qt/qt5-addons/qtglesstream.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-qt/qt5-addons/qtglesstream.bb b/recipes-qt/qt5-addons/qtglesstream.bb
new file mode 100644
index 0000000..96ab1f7
--- /dev/null
+++ b/recipes-qt/qt5-addons/qtglesstream.bb
@@ -0,0 +1,58 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://www.qt.io/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "QtGlesStream"
24LICENSE = "QtEnterprise"
25LIC_FILES_CHKSUM = "file://qtglesstream.pro;md5=e95d9351d26ed899188e02d44133cae0"
26
27inherit qt5-module
28
29SRC_URI = " \
30 git://qt-gerrit.it.local/QtRD-15810/qtglesstream.git;branch=${QT_BRANCH};protocol=ssh \
31 "
32
33PV = "1.0.0"
34SRCREV = "137d476b0e39eaaa6f35296b6bd962175e6ea5d6"
35QT_BRANCH = "dev"
36
37S = "${WORKDIR}/git"
38
39DEPENDS = "qtbase"
40RREPLACES_${PN} = "qtglesstream-dummy-client"
41RREPLACES_${PN}-dev = "qtglesstream-dummy-client-dev"
42
43do_install_append() {
44 install -m 0755 -d ${D}${includedir}/EGL
45 install -m 0755 ${S}/headers/EGL/* ${D}${includedir}/EGL
46
47 install -m 0755 -d ${D}${includedir}/GLES2
48 install -m 0755 ${S}/headers/GLES2/* ${D}${includedir}/GLES2
49
50 install -m 0755 -d ${D}${includedir}/GLES3
51 install -m 0755 ${S}/headers/GLES3/* ${D}${includedir}/GLES3
52
53 install -m 0755 -d ${D}${includedir}/KHR
54 install -m 0755 ${S}/headers/KHR/* ${D}${includedir}/KHR
55}
56
57# no not overwrite files from qtglesstream-dummy-client
58do_populate_sysroot[noexec] = "1"