summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5-addons/installer-framework_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5-addons/installer-framework_3.0.1.bb')
-rw-r--r--recipes-qt/qt5-addons/installer-framework_3.0.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-qt/qt5-addons/installer-framework_3.0.1.bb b/recipes-qt/qt5-addons/installer-framework_3.0.1.bb
new file mode 100644
index 0000000..5bc09c0
--- /dev/null
+++ b/recipes-qt/qt5-addons/installer-framework_3.0.1.bb
@@ -0,0 +1,50 @@
1############################################################################
2##
3## Copyright (C) 2017 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Installer Framework"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33
34inherit bin_package native
35
36do_unpack[depends] += "p7zip-native:do_populate_sysroot"
37
38SRC_URI = "http://download.qt.io/development_releases/installer-framework/${PV}/installer-framework-build-stripped-${PV}-linux-x64.7z"
39
40SRC_URI[md5sum] = "68b7c1f761ca0dba18f1d165d66005d6"
41SRC_URI[sha256sum] = "c2eb769351025e0c7df2882116390fffaf958368f873a2abab99e37caee0a498"
42
43S = "${WORKDIR}/ifw-pkg"
44
45do_install() {
46 install -d ${D}${bindir}
47 install -m 0755 -t ${D}${bindir} ${S}/bin/*
48}
49
50INSANE_SKIP_${PN} += "already-stripped"