summaryrefslogtreecommitdiffstats
path: root/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/meta/meta-b2qt-automotive-qbsp.bb')
-rw-r--r--recipes-qt/meta/meta-b2qt-automotive-qbsp.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
new file mode 100644
index 0000000..ebd12c5
--- /dev/null
+++ b/recipes-qt/meta/meta-b2qt-automotive-qbsp.bb
@@ -0,0 +1,47 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Meta task for QBSP creation"
31
32LICENSE = "The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
34
35# get Qt version number
36require recipes-qt/qt5/qt5-git.inc
37S = "${WORKDIR}"
38
39inherit qbsp
40
41PV = "1.1"
42
43QBSP_INSTALLER_COMPONENT = "qt.automotive.10.yocto.${MACHINE}"
44QBSP_INSTALL_PATH = "/${QT_MODULE_BRANCH}/Automotive/${MACHINE}"
45
46QBSP_SDK_TASK = "meta-toolchain-b2qt-automotive-qt5-sdk"
47QBSP_IMAGE_TASK = "b2qt-automotive-qt5-image"