summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images/b2qt-embedded-ci-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/images/b2qt-embedded-ci-image.bb')
-rw-r--r--recipes-qt/images/b2qt-embedded-ci-image.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/recipes-qt/images/b2qt-embedded-ci-image.bb b/recipes-qt/images/b2qt-embedded-ci-image.bb
new file mode 100644
index 0000000..09dbcf8
--- /dev/null
+++ b/recipes-qt/images/b2qt-embedded-ci-image.bb
@@ -0,0 +1,74 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt on embedded Linux SDK image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32PR = "r0"
33
34IMAGE_FEATURES += "\
35 package-management \
36 ssh-server-dropbear \
37 tools-debug \
38 debug-tweaks \
39 hwcodecs \
40 "
41
42inherit core-image
43
44IMAGE_INSTALL += "\
45 packagegroup-b2qt-embedded-base \
46 packagegroup-b2qt-embedded-tools \
47 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
48 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
49 packagegroup-b2qt-qt5-modules \
50 "
51
52ROOTFS_POSTINSTALL_COMMAND += "remove_qt_from_rootfs;"
53
54python remove_qt_from_rootfs() {
55 import subprocess
56
57 # remove qtbase and all dependent packages
58 image_rootfs = d.getVar('IMAGE_ROOTFS', True)
59 opkg_conf = d.getVar("IPKGCONF_TARGET", True)
60 opkg_cmd = bb.utils.which(os.getenv('PATH'), "opkg")
61 opkg_args = "--volatile-cache -f %s -o %s " % (opkg_conf, image_rootfs)
62 opkg_args += d.getVar("OPKG_ARGS", True)
63
64 cmd = "%s %s --force-remove --force-removal-of-dependent-packages remove %s" % \
65 (opkg_cmd, opkg_args, 'qtbase')
66
67 try:
68 bb.note(cmd)
69 output = subprocess.check_output(cmd.split(), stderr=subprocess.STDOUT)
70 bb.note(output)
71 except subprocess.CalledProcessError as e:
72 bb.fatal("Unable to remove packages. Command '%s' "
73 "returned %d:\n%s" % (e.cmd, e.returncode, e.output))
74}