summaryrefslogtreecommitdiffstats
path: root/recipes-qt/images/b2qt-automotive-qt5-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/images/b2qt-automotive-qt5-image.bb')
-rw-r--r--recipes-qt/images/b2qt-automotive-qt5-image.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb
new file mode 100644
index 0000000..b60d9a0
--- /dev/null
+++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb
@@ -0,0 +1,59 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt Automotive Qt5 image"
31LICENSE = "The-Qt-Company-DCLA-2.1"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b"
33PR = "r0"
34
35DEPLOY_CONF_TYPE = "Automotive"
36
37IMAGE_FEATURES += "\
38 package-management \
39 ssh-server-dropbear \
40 tools-debug \
41 debug-tweaks \
42 hwcodecs \
43 "
44
45inherit core-image
46inherit bootfs-image
47inherit consistent_timestamps
48
49MACHINE_EXTRA_INSTALL_QT ?= ""
50
51IMAGE_INSTALL += "\
52 ${MACHINE_EXTRA_INSTALL_QT} \
53 packagegroup-b2qt-embedded-base \
54 packagegroup-b2qt-embedded-tools \
55 ${@base_contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
56 ${@base_contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
57 packagegroup-b2qt-qt5-modules \
58 packagegroup-b2qt-automotive-addons \
59 "