summaryrefslogtreecommitdiffstats
path: root/recipes-qt/b2qt-addons/qdbd.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/b2qt-addons/qdbd.bb')
-rw-r--r--recipes-qt/b2qt-addons/qdbd.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/recipes-qt/b2qt-addons/qdbd.bb b/recipes-qt/b2qt-addons/qdbd.bb
new file mode 100644
index 0000000..b1c9a0d
--- /dev/null
+++ b/recipes-qt/b2qt-addons/qdbd.bb
@@ -0,0 +1,79 @@
1############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Qt Debug Bridge Daemon"
31SECTION = "devel"
32LICENSE = "The-Qt-Company-DCLA-2.1"
33LIC_FILES_CHKSUM = "file://qdbd/main.cpp;md5=37093977d3f09e6366def8955c8c71e6;beginline=1;endline=18"
34
35inherit qmake5
36
37SRC_URI = "git://codereview.qt-project.org/tqtc-boot2qt/qdb;branch=${BRANCH};protocol=ssh \
38 file://defaults \
39 file://qdbd.service \
40 file://qdbd-init.sh \
41 "
42
43SRCREV = "02a7d1ab030b83feb3300df5149b9ec0518975f4"
44BRANCH = "master"
45PV = "0.1+git${SRCPV}"
46
47DEPENDS = "qtbase"
48RRECOMMENDS_${PN} += "kernel-module-usb-f-fs kernel-module-usb-f-rndis"
49
50S = "${WORKDIR}/git"
51
52EXTRA_QMAKEVARS_PRE = "CONFIG+=daemon_only"
53
54do_configure_append() {
55 if [ -n "${ADB_PRODUCTID}" ]; then
56 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults
57 fi
58}
59
60do_install_append() {
61 install -m 0755 ${WORKDIR}/qdbd-init.sh ${D}${bindir}/
62 install -m 0755 -d ${D}${sysconfdir}/init.d
63 ln -s ${bindir}/qdbd-init.sh ${D}${sysconfdir}/init.d/
64
65 install -m 0755 -d ${D}${systemd_unitdir}/system
66 install -m 0644 ${WORKDIR}/qdbd.service ${D}${systemd_unitdir}/system/
67
68 install -m 0755 -d ${D}${sysconfdir}/default
69 install -m 0644 ${WORKDIR}/defaults ${D}${sysconfdir}/default/qdbd
70}
71
72INITSCRIPT_NAME = "qdbd-init.sh"
73INITSCRIPT_PARAMS = "defaults 96"
74
75SYSTEMD_SERVICE_${PN} = "qdbd.service"
76# adbd is started by default instead of qdbd
77SYSTEMD_AUTO_ENABLE = "disable"
78
79inherit update-rc.d systemd