summaryrefslogtreecommitdiffstats
path: root/recipes-qt/b2qt-addons/democompositor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/b2qt-addons/democompositor_git.bb')
-rw-r--r--recipes-qt/b2qt-addons/democompositor_git.bb35
1 files changed, 20 insertions, 15 deletions
diff --git a/recipes-qt/b2qt-addons/democompositor_git.bb b/recipes-qt/b2qt-addons/democompositor_git.bb
index e3ca81c..d63df0e 100644
--- a/recipes-qt/b2qt-addons/democompositor_git.bb
+++ b/recipes-qt/b2qt-addons/democompositor_git.bb
@@ -1,41 +1,46 @@
1############################################################################## 1############################################################################
2## 2##
3## Copyright (C) 2016 The Qt Company Ltd. 3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/ 4## Contact: https://www.qt.io/licensing/
5## 5##
6## This file is part of the Boot to Qt meta layer. 6## This file is part of the Boot to Qt meta layer.
7## 7##
8## $QT_BEGIN_LICENSE:COMM$ 8## $QT_BEGIN_LICENSE:GPL$
9##
10## Commercial License Usage 9## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in 10## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the 11## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in 12## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms 13## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further 14## and conditions see https://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us. 15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
17## 25##
18## $QT_END_LICENSE$ 26## $QT_END_LICENSE$
19## 27##
20############################################################################## 28############################################################################
21 29
22DESCRIPTION = "Boot to Qt Wayland Demo Compositor" 30DESCRIPTION = "Boot to Qt Wayland Demo Compositor"
23LICENSE = "QtEnterprise" 31LICENSE = "BSD | The-Qt-Company-DCLA-2.1"
24LIC_FILES_CHKSUM = "file://main.cpp;md5=56e7f80d726792929d5d089852de7cde;beginline=1;endline=39" 32LIC_FILES_CHKSUM = "file://main.cpp;md5=b0a1a6eef4a172b0a8cb4dad9a167d91;beginline=1;endline=49"
25 33
26inherit qmake5 34inherit qmake5
27require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
28 36
29QT_MODULE = "qt-apps-boot2qt-demos" 37QT_MODULE = "qt-apps-boot2qt-demos"
30 38
31SRCREV = "b6217fb2bb7702324da2a9f3f45be4a60e6ffe6c" 39SRCREV = "a6d8f7ce79fb5c17e706f25daf4dda4d97b5323e"
32 40
33S = "${WORKDIR}/git/wayland/democompositor/" 41S = "${WORKDIR}/git/wayland/democompositor/"
34 42
35DEPENDS = "qtbase qtwayland" 43DEPENDS = "qtbase qtwayland"
36RDEPENDS_${PN} = "qtwayland (>= 5.7)"
37 44
38do_install_append() { 45FILES_${PN} += "/data/user/democompositor"
39 install -d -m0775 ${D}/usr/bin 46FILES_${PN}-dbg += "/data/user/democompositor/.debug"
40 install -m0775 ${B}/democompositor ${D}/usr/bin
41}